wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes Probems in web.xml while migrating from Jboss-5.0.0Beta1 to Jboss-5.1.0GA Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Probems in web.xml while migrating from Jboss-5.0.0Beta1 to Jboss-5.1.0GA" Watch "Probems in web.xml while migrating from Jboss-5.0.0Beta1 to Jboss-5.1.0GA" New topic
Author

Probems in web.xml while migrating from Jboss-5.0.0Beta1 to Jboss-5.1.0GA

rohitj tcs
Greenhorn

Joined: Aug 14, 2009
Posts: 1
Hi All,

We migrated our web application from Jboss-5.0.0Beta1 to Jboss-5.1.0GA, but initially i faced problem which indicated changes to be brought in web.xml file hence i changed the header of web.xml (web-app tag) & now my web.xml is :



earlier when we used to work in Jboss-5.0.0Beta1 the only difference in web.xml was in web-app tag which was ...



still i am facing problem (exception which states)

DEPLOYMENTS IN ERROR:
Deployment "vfsfile:/local/dubeavi/jboss-5.1.0.GA/server/default/deploy/PerformanceMonitoringISE-1.0/" is in error due to the following reason(s): org.xml.sax.SAXException: cvc-complex-type.2.4.a: Invalid content was found starting with element 'init-param'. One of '{"http://java.sun.com/xml/ns/javaee":run-as, "http://java.sun.com/xml/ns/javaee":security-role-ref}' is expected. @ vfsfile:/local/dubeavi/jboss-5.1.0.GA/server/default/deploy/PerformanceMonitoringISE-1.0/WEB-INF/web.xml[29,15]


Can anyone please suggest what changes i should bring to web.xml, it will be kind if some one can provide me web.xml which is compatible to Jboss-5.1.0GA

Thanks in advance.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9956
    
163

"rohitj tcs"

Please click on the "My Private Messages" link on top of this page, for a message from JavaRanch.


[My Blog] [JavaRanch Journal]
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9956
    
163

As shown in the error message, the web.xml does not follow the xsd http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd

Specifically, the init-param in the servlet element should occur before the load-on-startup element.
 
 
subject: Probems in web.xml while migrating from Jboss-5.0.0Beta1 to Jboss-5.1.0GA
 
Similar Threads
Parsing error processing resource path /WEB-INF/struts-config.xml
JSP not able to find tag library descriptor | Struts 1.3 | Websphere App Server 7.0 | RAD 8.0
a question about struts....please help
error comes while running the struts application please see the source code for detail
error while creating struts application