File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes install JBoss+Rails beta on Ubuntu? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "install JBoss+Rails beta on Ubuntu?" Watch "install JBoss+Rails beta on Ubuntu?" New topic
Author

install JBoss+Rails beta on Ubuntu?

Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82

Hi

I downloaded the JBoss+jdk6+Rails Beta .zip file. Can anyone help me to install it?
I already have netbeans+jdk5+mysql+javaFX bundle installed. I would like to continue using netbeans, and I want to try JBoss also. If I install JBoss will it override jdk5 and create problem with netbeans?

Thanks in Advance,
George, Teena
SCWCD5
Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82
Hi

I tried running run.sh (sh run.sh). But im getting an exception:



I checked and no process is using port 8083. I believe i have do something before it...?

Regards,
George, Teena
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10288
    
168

java.lang.Exception: Port 8083 already in use.


Looks like there is already some process which is using 8083 port. Try



command and see which process is using that port. You can then kill that process and start the server. For other options see this wiki http://www.jboss.org/community/wiki/DebugBindException


[My Blog] [JavaRanch Journal]
Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82
Hi

Thank you. I got this:



I dont know how to kill a process without the PID
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10288
    
168

Try

Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82
Hi Jaikiran

Thanks a lot. Its started.


I think I just have the JBoss AS5 server. How do i develop some samples in JBoss IDE? should i download JBoss IDE separately? I dont have eclipse. i have netbeans, but i dont want to touch it. I remember i installed a single .exe in windows OS and i got the ide and app server together. If I need to get the IDE separately, where can i get it?

Thanks,
George, Teena
Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82
Hi

I think i have a problem with the server. i tried to test the server using http://localhost:8083/ but the JBoss home page didnt turn up. does it mean the server is not started properly?
Please find below the messages from sh run.sh:


Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10288
    
168

Teena George wrote:Hi

I think i have a problem with the server. i tried to test the server using http://localhost:8083/ but the JBoss home page didnt turn up.


The default HTTP port is 8080. So you will have to access it at http://localhost:8080 from the machine where the server is running.
Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82

I tried http://localhost:8080/ also. But it shows empty page.
I have doubt in my JAVA_HOME variable. If you could scroll to the top of the log i pasted on the previous post, it shows"



I checked the run.config file and it is like this:

Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10288
    
168

As per the logs the java version being used is:



Also, this log shows that the server started without any issues and should be accessible at localhost:8080. Are you accessing this from the same machine where the server is running? By default you cannot access the server remotely. For that you need to start using the -b option http://www.jboss.org/community/wiki/JBoss42FAQ
Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82


No, I am not remote conneted to the server machine. Its installed on the same machine from which I am trying to access it.
Also, I tried to set the JBoss server to my netbeans, but the ide throws a null pointer exception when i clicked on the 'Add..' button in the web application creation wizard.


Teena George
Ranch Hand

Joined: May 01, 2008
Posts: 82

Finally I configured JBoss v5.0 + Ruby server in my Eclipse 3.5. And i ran a sample web app also. There is one strange problem i have. I get an 'Adress already in use' error when i start jboss server first. Then i have to do a netstat to find out who is using that port and kill it. it is the same server process that uses the 8083. I understood it when i ran the server from one shell window and killed the process which was using the port from another shell window. I wonder why this is happening.

Thanks,
George, Teena
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: install JBoss+Rails beta on Ubuntu?