*
The moose likes Web Services and the fly likes Calling Axis2 WebService deployed on JBoss5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Calling Axis2 WebService deployed on JBoss5" Watch "Calling Axis2 WebService deployed on JBoss5" New topic
Author

Calling Axis2 WebService deployed on JBoss5

Amir Kost
Greenhorn

Joined: Aug 19, 2009
Posts: 8
Hi.

I have an Axis2-1.4 web service deployed on JBoss 5.0. When I call the service from a client I get the following exception: java.net.ConnectException
Connection refused: connect

I can navigate to the WSDL, and if I call the server from the browser with GET it works, but I cannot call it from a client. When I deploy it on Tomcat it works fine.

Can anyone help?

Thanks,

Amir
Trilochan Bharadwaj
Ranch Hand

Joined: Feb 02, 2009
Posts: 100
this might help:
Deploying Axis on JBOSS

Unless you have already resolved the issue, if so care to post what was the problem and how was it solved? We might learn something new, who knows...

Trilochan.

Addendum: Are you using "https" as opposed to "http", if so can you try without s and see if it makes a difference?
Amir Kost
Greenhorn

Joined: Aug 19, 2009
Posts: 8
I solved the problem. The problem was that the generated client used my computer's IP address, and JBoss was configured to run on localhost. There are 2 ways to solve this:

1. The better solution is to make JBoss run on the IP address and not on localhost. This is done by using the parameter -b when running JBoss. For example : run.bat -b 192.168.33.33

2. For the lazy people among us, if you are using Eclipse's Web Services Explorer you can add an endpoint using localhost instead of the IP address.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Calling Axis2 WebService deployed on JBoss5