my dog learned polymorphism
The moose likes BEA/Weblogic and the fly likes issue in starting weblogic server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "issue in starting weblogic server" Watch "issue in starting weblogic server" New topic

issue in starting weblogic server

nandini lagunia
Ranch Hand

Joined: May 05, 2009
Posts: 57
I am using WLST with python for creating weblogic domain and starting the server.
I can successfully create the domain using Ant. The problem is when I try to start
the server,it starts but doesn't return control. It just hangs. Although I can access

The Ant script that calls the python code is as follows...

and is as follows...

Any help would be greatly appreciated...
Deepak Bala

Joined: Feb 24, 2006
Posts: 6662

I have never used python, but it looks like your python code starts the server and then waits on that call. Like calling a method.

I am not sure if this makes sense but, is it possible to say start the server in its own thread in python ? I dont even know if that is possible or a good idea.

Usually ant tasks deploy to a server that is already running.

SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
nandini lagunia
Ranch Hand

Joined: May 05, 2009
Posts: 57
Even I don't know Python.
The same piece of code is running fine on linux and I don't have any clue why.
subject: issue in starting weblogic server
It's not a secret anymore!