Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Integration tests doesn't work after upgrading spring from 2.5.1 to (2.5.6.SEC01)

 
Anand Krishnanandam
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I recently upgraded spring from 2.5.1 to 2.5.6.SEC01, Struts from 2.0.11 to 2.1.6, hibernate to 3.3.1.

After upgrading my integration tests don't seem to work. My application is up and running fine. Its just that my test cases throw the following error.


I have been working to fix my integration tests for the past 2 days. I don't know why it would work on tomcat (my application runs fine) and not on my test cases. Does any of you come across such weirdness?
Any help would be greatly appreciated.

Thanks,
Anand.

 
Eduardo Bueno
Ranch Hand
Posts: 155
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Check your connection provider. This is probally a missing .jar or a XML typo. Post your sessionFactory declaration and connection retrieving methods (if any).
 
Anand Krishnanandam
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Thanks for the reply and your time.

This is the datasource config xml.


and this is the list of jars.



I checked out my project fresh, installed the jars and tried the tests as first thing. It gave me the same error. So I cannot think of any typo.

This doesn't make any sense. What was so different from 2.5.1 to 2.5.6.SEC01 that my application works and my test cases fail.

Does anybody has an answer? I am stuck for a week in this upgrade.

Thanks in advance for your help.



 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic