This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Spring and the fly likes Integration tests doesn't work after upgrading spring from 2.5.1 to (2.5.6.SEC01) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Spring
Bookmark "Integration tests doesn Watch "Integration tests doesn New topic
Author

Integration tests doesn't work after upgrading spring from 2.5.1 to (2.5.6.SEC01)

Anand Krishnanandam
Greenhorn

Joined: May 23, 2006
Posts: 25
Hi,
I recently upgraded spring from 2.5.1 to 2.5.6.SEC01, Struts from 2.0.11 to 2.1.6, hibernate to 3.3.1.

After upgrading my integration tests don't seem to work. My application is up and running fine. Its just that my test cases throw the following error.


I have been working to fix my integration tests for the past 2 days. I don't know why it would work on tomcat (my application runs fine) and not on my test cases. Does any of you come across such weirdness?
Any help would be greatly appreciated.

Thanks,
Anand.

Eduardo Bueno
Ranch Hand

Joined: Jun 04, 2009
Posts: 155

Check your connection provider. This is probally a missing .jar or a XML typo. Post your sessionFactory declaration and connection retrieving methods (if any).
Anand Krishnanandam
Greenhorn

Joined: May 23, 2006
Posts: 25
Hi,
Thanks for the reply and your time.

This is the datasource config xml.


and this is the list of jars.



I checked out my project fresh, installed the jars and tried the tests as first thing. It gave me the same error. So I cannot think of any typo.

This doesn't make any sense. What was so different from 2.5.1 to 2.5.6.SEC01 that my application works and my test cases fail.

Does anybody has an answer? I am stuck for a week in this upgrade.

Thanks in advance for your help.



 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Integration tests doesn't work after upgrading spring from 2.5.1 to (2.5.6.SEC01)
 
Similar Threads
method injection problem
Spring+Hibernate can't create SessionFactory bean
SEVERE: Context initialization failed org.springframework.beans.factory.BeanCreationException
LOrdering Error wile starting Tomcat 7 server using Richfaces 4.1 and JSF 2.0
Spring jndi in context.xml / MyEclipse / Oracle / SJAS 9.1