aspose file tools*
The moose likes Other Open Source Projects and the fly likes having Problem about JSTL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "having Problem about JSTL" Watch "having Problem about JSTL" New topic
Author

having Problem about JSTL

aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38
Hi everybody..

This is the first time I am using JSTL, I read lots of articles about it, and tried to follow everything step by step, But
I am really stuck in a problem about using the JSTL. I use JBoss 4.2.3 . I downloaded the jstl 1.2 and copied the jstl.jar under
C:\jboss-4.2.3.GA\lib directory. And also because I am trying to use the datagrid, I coppied " taglibs-datagrid.jar " under the same directory.
Then I coppied "taglibs-datagrid.tld" under my WEB-INF folder.

I am having this problem:

unable to load tag handler class "org.apache.taglibs.datagrid.DataGridTag" for tag "ui:dataGrid"

Any idea, please help me....

Thanks in advance..

my web.xml file is :

...

and my jsp file is:

David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Please review your post--it's essentially impossible to read.

Please UseCodeTags. Unformatted code/config/etc. is difficult to read. You can edit your post to include them using the button or re-post the question with proper formatting.

You should also disable HTML if your fragments include valid HTML.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61237
    
  66

taglibs has nothing to do with the JSTL.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

This seems to be an issue with the datagrid tags, not JSTL.
aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38
Hello;

I am having a different error message now:

"According to TLD or attribute directive in tag file, attribute items does not accept any expressions "

I searched on the Internet and it was advised to use



I tried this as well



But still giving the same problem.. I dont know am I using the correct version for jstl? Or is there something else?


I changed my jsp codes to :


Sorry about the previous post as it was not really readable..
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Seriously: use code tags, or your messages are likely to be ignored because they're difficult to read.

I provided instructions.
aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38

Thanks David for your suggestion;

My Post now looks much better..
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61237
    
  66

Again, if your problem is with the 3rd-party tag libraries, the JSTL stuff is moot. Are you sure that you know which tags are causing the issues?
aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38
I really dont know. When I delete the code below, it works with no error and naturally does not show anything..

David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

What's the rest of the exception? What version of JSP/servlet does the taglib support? What version of JSP/servlet does your server support?
aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38

1. Server info: JBossWeb/2.0.1.GA
2. Servlet version: 2.5
3. JSP version: 2.1
4. Java version: 1.6.0_10
aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38
Many thanks..
Here is all about the error I am having, I got it from my JBoss log file.

The line 76 refers to



The error:

David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

So there's your answer:First of all, the <%= ... %> syntax will display a string--I would have assumed you want to pass a collection of some sort. Second, the <% ... %> won't be allowed there. Just pass the collection directly.

It's really nice to provide the relevant information up front and to be accurate in the subject line--as noted, this wasn't a JSTL problem, and the important part of the exception message wasn't shown until now.
aydeniz kirmizi
Ranch Hand

Joined: Aug 20, 2009
Posts: 38
Hello

I am really sorry about all these posts. This was the first time I was using this site, I did not know how to use it..

And the other thing is, I had never used or heard about JSTL till yesterday. I want to use it for my final project.
I did not even know which details I must send.. But any way, thanks you all for your patience..

I changed my codes to:



But it gives exception for exactly the same line, which is :



Many thanks..



 
It is sorta covered in the JavaRanch Style Guide.
 
subject: having Problem about JSTL