File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Deployed Tapestry 5 web app not working in Tomcat 5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of JavaScript Promises Essentials this week in the JavaScript forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Deployed Tapestry 5 web app not working in Tomcat 5" Watch "Deployed Tapestry 5 web app not working in Tomcat 5" New topic
Author

Deployed Tapestry 5 web app not working in Tomcat 5

Stefan Mohr
Greenhorn

Joined: Mar 11, 2008
Posts: 14
Hi folks,

I'm having a frustrating issue here:

I've got a WAR project built using Maven that makes extensive use of Tapestry 5 and Hibernate.
I'm trying to deploy it to a Tomcat server (5.5.28) and have no problems. I've been using the web interface to deploy it and it loads the app and starts it successfully (at least as far as I can tell - the Stop button is enabled and Start is disabled.. I can start and stop it without issue).

The only problem is, when I try to navigate to the web app, I get a standard Tomcat error page:



Returning to the Tomcat web console again shows it is deployed and started.


Curiously enough, the Tomcat logs show nothing except for regular status messages indicating that the app server started correctly and that my app deployed successfully. No errors, no warnings, nada.

It's been tested on a couple of servers, but the current server environment is Windows Server 2003 R2 x64.

Any thoughts? I can't find any meaningful error information anywhere which makes it miserable to troubleshoot.


Thanks!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deployed Tapestry 5 web app not working in Tomcat 5