Meaningless Drivel is fun!*
The moose likes Ranch Office and the fly likes Interesting UBB tag mismatch bug? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » This Site » Ranch Office
Bookmark "Interesting UBB tag mismatch bug?" Watch "Interesting UBB tag mismatch bug?" New topic
Author

Interesting UBB tag mismatch bug?

David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

So I had a message posted that opened w/ a code tag and tried to close it with a quote tag.

In the "My Posts" section it rendered like this: (Hmm, just realized I have no idea how to embed a pic.)

It's attached. And embedded.



Fix the mis-matched tag, weird My Posts render thing goes away.



[Thumbnail for Picture 1.png]

Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42282
    
  64
What do you mean by "weird My Posts render thing"? The font size looks a bit bigger than normal, but otherwise it seems fine. Am I missing something?


Ping & DNS - my free Android networking tools app
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Yeah--that's shown without expanding the "details" link...
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

This is the expanded version:





[Thumbnail for Picture 2.png]

Sagar Rohankar
Ranch Hand

Joined: Feb 19, 2008
Posts: 2902
    
    1

I have the same problem, please see the below link, where you can found what happened if UBB tag is not closed
[ See thread subject: [+] Servlets ยป Garbage collection in Struts application ]
http://www.coderanch.com/forums/posts/listTopicsByUser/7/1/165494

[LEARNING bLOG] | [Freelance Web Designer] | [and "Rohan" is part of my surname]
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30762
    
156

I can reproduce this on my machine. I'll debug it later.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30762
    
156

The problem was a span tag where a div should be. It will be fixed in the next deployment.
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Cool; thanks :) Oh, in the UBB tag stuff you mean?
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30762
    
156

David Newton wrote:Cool; thanks :) Oh, in the UBB tag stuff you mean?

Not really. The div/span was around the code. When UBB tags were mismatched, they had a span in them. Which messed things up.
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42282
    
  64
This fix has been released.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Interesting UBB tag mismatch bug?