This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes IDEs, Version Control and other tools and the fly likes doubt on '-server' parameter being ignored on eclipse IDE initialization Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "doubt on Watch "doubt on New topic
Author

doubt on '-server' parameter being ignored on eclipse IDE initialization

Carlos Angelim
Greenhorn

Joined: Jul 23, 2009
Posts: 4
Hi ranchers,

While tuning my eclipse.ini file, i noticed, with visualVM, that although the -server parameter was read, the java vm itself was running in client mode.

This will only happen on win32 machines because in 64 bits and other (decent) OS the vm itself is able to determine its mode.

For those interested, here's the data:
Runtime Platform: Hotspot VM (Sun's jdk 1.6.0_14) 32 bits on Windows XP
Eclipse: 3.5 (Galileo)

eclipse.ini file contents:


If you run visualvm and connect it to the eclipse process, you will see the '-server' parameter under the tab 'jvm arguments'. But it shows, in the overview tab, the JVM as 'Java HotSpot(TM) Client VM (14.0-b16, mixed mode)'

I suspect that's related to the equinox's initialization, I tried the -server parameter on other parts of the eclipse.ini file to no avail.

Does anyone know more about this issue?

Thanks in advance,
Carlos



[Thumbnail for eclipse_visualvm.JPG]

javier far
Greenhorn

Joined: Mar 29, 2011
Posts: 1
Hi Carlos,

I entered the same issue, just found out how to use Eclipse on Windows within a 32-bit Server JVM.

Just add the lines
***
-vm
[your JRE path]\bin\server\jvm.dll
***

Best regards (e esperando não chegar tarde demais ),

Javier Far
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5812
    
    7

The problem is that "-server" is not a VM argument. Rather, it is an argument that is identified and acted upon by the VM loaded (usually java.exe). I suspect that eclipse.exe is loading the client VM, which then ignores the "-server" option. So the trick would be to get eclipse.exe to recognize that you want to use the server, rather than the client, VM and thus load the proper one. Javier's solution is perfect for this.


JBoss In Action
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: doubt on '-server' parameter being ignored on eclipse IDE initialization
 
Similar Threads
Eclipse is running in a JRE, but a JDK is required
Compilation error
Internal error occurs during building workspace ?
Since I want to use maven in my IDE should I dump eclipse for intellij
eclipse3.5 giving OutOfMemory/Permgen after installing plugin for Spring IDE