aspose file tools*
The moose likes Struts and the fly likes Struts Servlet Action not available error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts Servlet Action not available error" Watch "Struts Servlet Action not available error" New topic
Author

Struts Servlet Action not available error

Hung Tang
Ranch Hand

Joined: Feb 14, 2002
Posts: 148
does anyone know what this means? im trying to invoke an action and this error message comes up:

?? Anyone
thanks
Adam Hardy
Ranch Hand

Joined: Oct 09, 2001
Posts: 566
I would guess it means that your struts action servlet has not loaded or has died. Look in your log files to see if any exceptions were logged.
Good luck,
Adam


I have seen things you people would not believe, attack ships on fire off the shoulder of Orion, c-beams sparkling in the dark near the Tennhauser Gate. All these moments will be lost in time, like tears in the rain.
Tong Lin
Greenhorn

Joined: Mar 24, 2004
Posts: 12
I am using j2ee1.3.1 sun ri with struts 1.1. I got the same error message when I tried to invoke struts-blank...
[ April 22, 2004: Message edited by: Tong Lin ]
Tong Lin
Greenhorn

Joined: Mar 24, 2004
Posts: 12
O, I searched the internet, and see somebody said you should comment out
the tile plugin and tile controller in struts-config.xml. I tried and
struts app works.
I wonder why j2ee1.3.1 ri does not like the tile definition in struts-config.xml. j2ee1.3.1 does not tile or sun ri? Anybody any experience?
naraharirao mocherla
Ranch Hand

Joined: Aug 16, 2005
Posts: 45
Hi,

I also got the same problem.So when I removed controller and plug-in tags.it worked fine.
what is the reason???

thanks,
narahari
 
Consider Paul's rocket mass heater.
 
subject: Struts Servlet Action not available error