jQuery in Action, 3rd edition
The moose likes Struts and the fly likes struts login example issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "struts login example issue" Watch "struts login example issue" New topic

struts login example issue

Mathew Lee
Ranch Hand

Joined: Jun 08, 2009
Posts: 238

I am trying to run a struts 1.1 login example in RAD 7.0 within websphere 6.1 server. My code looks as follows. It has simple form, action, three simple jsps and a validation. When i try to run it giving error saying 'unable to locate tag library tags-html as in attachment

ApplicationResources.properties looks like

userLogin.jsp looks like

userLoginSuccess looks like

struts-config looks like

web.xml looks like

UserLoginAction looks like

userLoginForm looks like

i tried to add struts-taglib-1.3.8 from location D:\Program Files\Genuitec\MyEclipse 7.5\configuration\org.eclipse.osgi\bundles\10\1\.cp\lib but says duplicate entry( by the way same application with same code working fine in myEclipse not in RAD...in RAD it is going to index page but within that page when i click

'click here' giving error message like tags-html

as in screenshot.

I tried to add the taglib

as given in above link and some syntax errors coming in web.xml. Please advise on how i can resolve it.

Any ideas, suggestions, sample code, links highly appreciated. Thanks in advance.

[Thumbnail for strutsError.jpg]

David Newton

Joined: Sep 29, 2008
Posts: 12617

Why would you try to use the tag libraries from 1.3 in a 1.1 app?! Why would you use 1.1 at all, for that matter?

What Struts lib(s) are you deploying, and where are they located in your app hierarchy?
I agree. Here's the link: http://aspose.com/file-tools
subject: struts login example issue
It's not a secret anymore!