aspose file tools*
The moose likes Tomcat and the fly likes Tomcat compatibility with JRE 1.6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat compatibility with JRE 1.6" Watch "Tomcat compatibility with JRE 1.6" New topic
Author

Tomcat compatibility with JRE 1.6

suresh nuzella
Greenhorn

Joined: Aug 30, 2009
Posts: 10
Hi,

Can any one explain me whether tomcat 5.0.28 is compatible with JRE 1.6 or I need to install any other version of tomcat?Also what are the general things we need to consider when we are upgrading to JRE 1.6 from 1.4x

Please do the needfull.

Vijitha Kumara
Bartender

Joined: Mar 24, 2008
Posts: 3825

Tomcat 6.0 designed to run on JSE 5.0 and later. Check the docs for more info.


SCJP 5 | SCWCD 5
[How to ask questions] [Twitter]
suresh nuzella
Greenhorn

Joined: Aug 30, 2009
Posts: 10
that means I need to change the version of my tomcat?
suresh nuzella
Greenhorn

Joined: Aug 30, 2009
Posts: 10
please help me on this whether I need to change my tomcat version or the older version(5.0.28) will serve the purpose?
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16014
    
  20

You can run Tomcat5 with JDK 6. Although there's been talk about a Tomcat that runs under just a JRE, as far as I know, they all still require the full JDK.

This isn't Microsoft where version dependency breakage is an ordinary part of life. Java was expressly designed to support backwards compatibility.

It's not a bad idea to move to Tomcat6, though. There's relatively little trauma in moving from TC5.5 to TC6.


Customer surveys are for companies who didn't pay proper attention to begin with.
suresh nuzella
Greenhorn

Joined: Aug 30, 2009
Posts: 10
thanks for your reply
 
Consider Paul's rocket mass heater.
 
subject: Tomcat compatibility with JRE 1.6