aspose file tools*
The moose likes Java Micro Edition and the fly likes Required softwares for j2me Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Mobile » Java Micro Edition
Bookmark "Required softwares for j2me " Watch "Required softwares for j2me " New topic
Author

Required softwares for j2me

VenuGopal Reddy P
Greenhorn

Joined: Sep 01, 2009
Posts: 9
Hi,

I am new to j2me.I would like to install j2me on windows.I don't know the softwares which required for j2me programming and where can i get it from. Please help me.

Thanks,
Venu
Peter Miklosko
Ranch Hand

Joined: May 26, 2009
Posts: 76
You will
  • need to have Java SE Development Kit - JDK 1.6 or higher (download here)

  • You need to download WTK:
  • either from SUN where you can use either little older WTK 2.5.2(more tutorials) or latest Java ME SDK 3.0
  • or from any other mobile provider (Nokia, Sony Ericssson etc) - here you can find list of them


  • All necessary coding you can do through any text editor or your favourite IDE (IntelliJ IDEA< Eclipse, NEtBEans etc)
    VenuGopal Reddy P
    Greenhorn

    Joined: Sep 01, 2009
    Posts: 9
    Thank you Peter
    Peter Miklosko
    Ranch Hand

    Joined: May 26, 2009
    Posts: 76
    No problem, for reading suggestion I would recommend one of Jonathan Knudsen books either Beginning J2ME: From Novice to Professional (here is limited online preview or newer version call Kicking Butt with MIDP and MSA: Creating Great Mobile Applications (Amazon link)
     
    jQuery in Action, 2nd edition
     
    subject: Required softwares for j2me