Two Laptop Bag*
The moose likes Applets and the fly likes Only parts of applet displaying when on webpage Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Applets
Bookmark "Only parts of applet displaying when on webpage" Watch "Only parts of applet displaying when on webpage" New topic
Author

Only parts of applet displaying when on webpage

Michelle Kyamo
Greenhorn

Joined: Aug 25, 2009
Posts: 18
My applet works fine when I test it on my pc (through Eclipse).

When I put it on a webpage though, it does not work. The webpage shows a blank screen at first, but through reloading the page and/or clicking, part of it shows. Once I get the slider to show and drag it around, some of the parts of the applet that change do show, but some display weird and some not at all.

You can look at the problem here (Edit: link removed because error is fixed).

ETA: I fixed the problem. It wasn't finding one of my images properly. I'm still surprised that something like that would cause such havoc with the rest of the applet though. Why wouldn't it display everything except the broken picture?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Only parts of applet displaying when on webpage
 
Similar Threads
webview not responding to touch events
WebPage can't run applet as signed after another signed applet is disabled
Applet to Javascript communication
JApplet - works on windows not on Linux
Loading Webpage in JFrame