wood burning stoves 2.0*
The moose likes BEA/Weblogic and the fly likes Tomahawk/Ajax/Rich Faces/JSF Compatibility Issues with WL 10.3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Tomahawk/Ajax/Rich Faces/JSF Compatibility Issues with WL 10.3" Watch "Tomahawk/Ajax/Rich Faces/JSF Compatibility Issues with WL 10.3" New topic
Author

Tomahawk/Ajax/Rich Faces/JSF Compatibility Issues with WL 10.3

Bern Ol
Greenhorn

Joined: Sep 01, 2009
Posts: 3
Does anyone have a correct suite of JAR files to use when trying to use Tomahawk, Rich Faces and JSF together in WL 10.3. I had a perfectly working appliction with WL 10.0 MP1, and now with 10.3 using the Jrockit 160_05 supplied with WL 10.3, my application is not working correctly anymore. It's like the client-side JSF DOM tree is getting mangled somehow. Pulldown menus are not responding with the correct navigation to the next page.

Values are not being filled in with ajax anymore and I have gotten a "Resources framework is not initialised, check web.xml for Filter configuration" error from javax.faces.FacesException originating from the org.ajax4jsf.resource.ResourceBuilderImpl.getWebXml.

WebLogic is running on site in a clustered environment with many users. I cannot reproduce the problems on my single server localhost box.

The versions of JSF I'm using are myFaces 1.1.4, Tomahawk 1.1.3, RichFaces/Ajax 3.1.4.GA, JSP 2.0, JSTL jakarta-taglibs-standard-1.0.6.

Any help is much appreciated, Bernadette
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

Can you post a stack trace ?

Did you make any code change when you moved to 10.3 or was the application simply migrated ? Did you recompile against the new jars ? Do you see class not found errors or the like ?


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
Bern Ol
Greenhorn

Joined: Sep 01, 2009
Posts: 3
They just migrated the WL from 10.0 MP1 to 10.3.

I am using jars at least 2 years old. I can't get a stack trace on this network, but sometimes it says that the "Resources framework is not available" for ajax. I have seen other posts of incompatibility. I'm going to try to set the prefer-web-inf-libs switch to see if that helps at all. I think it's a classpath issue. Any ideas ?

The code will work about 20% of the time correctly on pages that have a4j and rich faces included on them. However in a testbed, all seems to work better (less users, but still in a clustered weblogic env.
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

Without a stack trace, any attempt to solve the problem would be a wild goose hunt. You need to upgrade JARS and perform other tasks when you move between versions. Your errors seem inconsistent and are replicating only in certain scenarios ? Well, hard to say what the problem is without an error or stacktrace to go with it
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Tomahawk/Ajax/Rich Faces/JSF Compatibility Issues with WL 10.3
 
Similar Threads
Calling servlet from JSF applications
JSF + AJAX + RichFaces
Migrating to JSF 2.0
Implementation of Tiles with RichFaces
JSF - Unable to call servlet