This week's book giveaway is in the OCPJP forum.
We're giving away four copies of OCA/OCP Java SE 7 Programmer I & II Study Guide and have Kathy Sierra & Bert Bates on-line!
See this thread for details.
The moose likes Applets and the fly likes applet won't update with latest version Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "applet won Watch "applet won New topic
Author

applet won't update with latest version

verduka fox
Ranch Hand

Joined: Jan 18, 2001
Posts: 178
I have an applet within a portlet (IBM portlet API) on WebSphere Portal Server 6.1. The applet has been in production for a few months, with no issues. I'm about to deploy some changes, so I've asked various people to test the updates. Four people have experienced this scenario: when the applet displays, it displays an old version, a version that is no longer on the server, and that they would not have previously downloaded to their PC. We have tried various solutions to correct the issue: (1) for one user, the solution was to uninstall and reinstall the same version of Java (1.5.0_11); (2) for another user, the solution was to rebuild their LDAP profile; (3) for another user, we tried both of these solutions, and neither resolved the issue; (4) the last user, we are keeping as a test case so we haven't tried a solution. I have even tried renaming the applet jar: the last user (case 4 above) still displayed the outdated applet. I checked the list of applets in the Java control panel, and the newly renamed version is listed, it just isn't being used. It's like this old applet is cached on the PC, but I don't know where to look.

I've searched online about adding cache_archive and cache_option, but they have me a little confused. If this could correct my problem, please explain in more depth.

Here's my object tag to load the applet:


This has me extremely baffled. This problem is delaying a production release, so prompt replies are greatly appreciated. Thanks in advance.
verduka fox
Ranch Hand

Joined: Jan 18, 2001
Posts: 178
Any ideas?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42359
    
  64
Well, since you asked about "any" ideas... have you tried using an "applet" tag instead of this complicated (and nested!) "object" tag? Using the "object" tag for applets is really a relic from the past; much better to use "applet" these days.


Ping & DNS - my free Android networking tools app
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: applet won't update with latest version