aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes General Eclipse Slowness Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "General Eclipse Slowness" Watch "General Eclipse Slowness" New topic
Author

General Eclipse Slowness

Joe Adams
Greenhorn

Joined: Aug 26, 2009
Posts: 5
Hi,

They are making me run Eclipse on a regular Pentium 4 and the hourglass will go up for minutes at a time if my code contains an error.

Are there any good tricks to make Eclipse not give as much hourglass?

Can I change it's settings so it doesn't look for the cause of errors or anything like that?

I thank you in advance!
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

There are a lot of settings that can be tweaked in the settings.

How much RAM do you have? Are you configured to run with more than the default Java heap/permgen size?
Joe Adams
Greenhorn

Joined: Aug 26, 2009
Posts: 5
I have 2 gigabytes of RAM. Eclipse usually uses around 380M.

My eclipse.ini says this:

-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-product
org.eclipse.epp.package.jee.product
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Hmm, don't know then--if it's not swapping it shouldn't be particularly slow. Maybe try tweaking highlighting and decoration options?
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14268
    
  21

Are you talking about regular Java code or something else, for example XML?

Eclipse by default tries to validate XML, and sometimes it tries to download DTD or XSD files from Internet to do that, and that can sometimes take a long time.


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 8 API documentation
Joe Adams
Greenhorn

Joined: Aug 26, 2009
Posts: 5
Thanks for the input.

I'm just writing regular Java code but that is what it takes a long time to validate. I misspell a variable or something and then it gives me the red underline goes hourglass often for more than a minute. I'm thinking if I could turn off some kind of code validation that it does, I could run a lot faster.
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Try upping the -Xmx value as a sanity check, like to 1024m. I've run Eclipse (3.3, anyway, maybe 3.4) on a P4 w/ not a lot of RAM and never saw behavior like that.
Joe Adams
Greenhorn

Joined: Aug 26, 2009
Posts: 5
It'll let me go up to 768m, but it won't start if I do 1024. I also took a nature added to my .project for some proprietary sdk I'm using. I'll report back if I have any major breakthroughs.

Again, thank you for all you advice.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5836
    
    7

Try turning off automatic compilation, that might help.


JBoss In Action
Joe Adams
Greenhorn

Joined: Aug 26, 2009
Posts: 5
Update:

Okay. Since my problem was always caused by Eclipse looking for errors, I did the following and it seems to be helping.

I went Window>Preferences. I followed the side menus Java>Editor>Content Assist. From there I unchecked Enable auto activation, which is near the bottom.

Now it doesn't try to help me find errors unless I click on the red lines. Of course, since it was just giving me an hourglass for minutes and never actually suggesting solutions, this is preferable.
 
wood burning stoves
 
subject: General Eclipse Slowness