aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes JSP debug for Eclipse 5.0 and weblogic 9.2 MP2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "JSP debug for Eclipse 5.0 and weblogic 9.2 MP2" Watch "JSP debug for Eclipse 5.0 and weblogic 9.2 MP2" New topic
Author

JSP debug for Eclipse 5.0 and weblogic 9.2 MP2

Acharya Thiyagarajan
Greenhorn

Joined: Aug 01, 2009
Posts: 18
Hi,

I used the link (http://download.oracle.com/docs/cd/E13224_01/wlw/docs103/guide/ideuserguide/servers/conWebLogicServer.html#UpdateServerDefn) to debug jsps in eclipse. I have eclipse 5.0 and oepe plugin to integrate my weblogic 9.2 MP2 server to eclipse 5.0. I have given the weblogic.xml as below


There is a folder called jsp_servlet which inturn contains folders with the same name as the original folder the one which contains the jsp but with a underscore added to it and is created under C:\eclipse_5_0\eclipse\workspace\Folder. the .java and the .class files are getting generated. When I debug the jsp the control is correctly coming to the breakpoint but it still says edit source lookup. under my source look up I have added the workspace folder and also this jsp_servlet folder. Please help me in the same. We are stuck in an issue which can be solved if I can debug this.

Regards,
Acharya
Acharya Thiyagarajan
Greenhorn

Joined: Aug 01, 2009
Posts: 18
Hi,

I also quite dont understand the below lines under "Step 3: (Optional) Enabling JSP Servlet Source Debugging on Separate Server "

To enable source debugging of servlets on a separate server, map the following directory (on the remote server) to a local directory, and use the Source Lookup Path dialog, or the Source tab in the Launch Configuration dialog (the Run > Run command), to add the mapped directory to Source Lookup Path.

Have I configured teh same correctly as per the above statement?

Regards,
Acharya
Nishan Patel
Ranch Hand

Joined: Sep 07, 2008
Posts: 688

Hi Acharya ,

Pleace code tag when your question contains code.

read this Use Code Tags ..


Thanks, Nishan Patel
SCJP 1.5, SCWCD 1.5, OCPJWSD Java Developer,My Blog
Acharya Thiyagarajan
Greenhorn

Joined: Aug 01, 2009
Posts: 18
Hi,

I have done the same. sorry coz I am new to java ranch.

Regards,
Acharya
Nishan Patel
Ranch Hand

Joined: Sep 07, 2008
Posts: 688

It's Ok... don't be sorry...
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61413
    
  67

Please be sure to ask IDE questions in the IDE forum. I have moved this post there for you.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSP debug for Eclipse 5.0 and weblogic 9.2 MP2