wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes EJB 2.0 and Xdcolet problems! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "EJB 2.0 and Xdcolet problems!" Watch "EJB 2.0 and Xdcolet problems!" New topic
Author

EJB 2.0 and Xdcolet problems!

Srikanth Madasu
Ranch Hand

Joined: Sep 10, 2008
Posts: 48

Hi All, I am a newbie to EJB. I did a fair amount of research on EJBs and now comfortable with all the basic. SO I decided to do a sample project - but I am struck on this

I m trying the sample provided in this link - http://www.eclipse.org/webtools/community/tutorials/ejbtutorial/buildingejbs.html

But the Xdoclet never generated the files for me, it throws some Doclet exception. Can anyone tell me the reason for this exception and help me run this sample project sucessfully?

Thanks in advance....



If it's easy.. then everybody would do it!
Stefaan Somers
Greenhorn

Joined: Oct 08, 2009
Posts: 2
Hi,

I've got the same problem. But after a whole bench of googling still haven't found the solution.
Have you found a solution in the mean time??
Paul Sturrock
Bartender

Joined: Apr 14, 2004
Posts: 10336

EJB2 & Xdoclet? Any reason you are using these old technologies? Is it a legacy application?


JavaRanch FAQ HowToAskQuestionsOnJavaRanch
Ganesh Parasuraman
Greenhorn

Joined: Jan 18, 2010
Posts: 4
Hi,
If you are using EJB 2.0 and XDoclet 1.2.3 in Eclipse IDE then problem might be the EJBSession implemented methods in the class HelloBean.
Please remove all the implemented methods expect the constructor. i.e from the line number the XDoclet is throwing exceptions.
I tried this and worked fine for me.

Please let me know whether it worked for you or not and if you have already resolved the problem please share it so that I can also try that method.

Thanks
Sanjib Pal
Greenhorn

Joined: Feb 08, 2010
Posts: 27
Hi

I have experience with this problem. Please change the jre path to MyEclipse jre from Build Path Configuration. I think it will solved.

Thanks,
Sanjib


SCJP 5.0
Try unless you get the ultimate success.
dongjun keum
Greenhorn

Joined: Nov 11, 2010
Posts: 1
To. Sanjib Pal

Hi. Sanjib Pal~

Please understand I have the grammar wrong.

How do I change the build path should we do?

According to the JRE in eclipse properties Execution environment, Alternate JRE, Workspace default JRE should I choose, what are you in?

How to ask for more.

Thanks. ^^
Brian Lavender
Greenhorn

Joined: Nov 21, 2010
Posts: 1
I am following the Eclipse Web Tools Platform by Naci Dai et al and when I use xdoclet I have to tell the project that it is xdoclet project. Just adding the xdoclet facet does not do it.

Net -> EJB Project
Configuration -> "EJB Project with XDoclet"

brian
wiesel ac
Greenhorn

Joined: Jul 08, 2011
Posts: 1
Today I handled some legacy code and I got the same stack trace as mentioned above.

The solution was to disable Eclipse Save-actions. Concrete, in my Eclipse configuration the Save-actions add missing Override-annotations. These annotations seem to be unparseable for XDoclet and cause the shown exception.

Maybe this hint saves someone else a lot of debugging time.

Best wishes!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: EJB 2.0 and Xdcolet problems!