aspose file tools*
The moose likes Other Open Source Projects and the fly likes Quartz Sheduler not executing Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "Quartz Sheduler not executing" Watch "Quartz Sheduler not executing" New topic
Author

Quartz Sheduler not executing

Justin Howard
Ranch Hand

Joined: Feb 19, 2009
Posts: 162
Hi All,

Please help me fix the problem. I am using quartz-all-1.6.4.jar. I made sure it is there in the classpath. I also made sure the quartz.properties is present in the classpath.
I have this in my quartz.properties


I have this in the logs


I dont see any problems in the logs, but the job does not execute.

This is my initialization servlet


This is in the web.xml


Thanks!
Rob Spoor
Sheriff

Joined: Oct 27, 2005
Posts: 19785
    
  20

Moving to Other Open Source Projects.


SCJP 1.4 - SCJP 6 - SCWCD 5 - OCEEJBD 6
How To Ask Questions How To Answer Questions
Martijn Verburg
author
Bartender

Joined: Jun 24, 2003
Posts: 3274
    
    5

I would add more logger.debug statements and see exactly where it last logs something....


Cheers, Martijn - Blog,
Twitter, PCGen, Ikasan, My The Well-Grounded Java Developer book!,
My start-up.
Sagar Rohankar
Ranch Hand

Joined: Feb 19, 2008
Posts: 2902
    
    1

May be the Job is not getting created because of this problem


[LEARNING bLOG] | [Freelance Web Designer] | [and "Rohan" is part of my surname]
Justin Howard
Ranch Hand

Joined: Feb 19, 2009
Posts: 162
Thanks for the reply.
The authenticate filter is just for check if the user is logged in or not.

I am using the same configuration for another project , it works fine.

Thank you.
Justin Howard
Ranch Hand

Joined: Feb 19, 2009
Posts: 162
Hi All,

I am getting an error in the web.xml for <init-param> in eclipse.


It reads ,
Invalid content type found at init-param. One of {urls} is expected.
Could that be the problem ?

Thanks
Sagar Rohankar
Ranch Hand

Joined: Feb 19, 2008
Posts: 2902
    
    1

Justin Howard wrote:Invalid content type found at init-param. One of {urls} is expected.

No, that couldn't be the problem.

I'm more interested in this logs
Justin Howard
Ranch Hand

Joined: Feb 19, 2009
Posts: 162
Thank you for the reply.
Those never came up in the logs. I had given a few more log statements. "Here 2" was the last staement in the logs. The PasswordReset class is present in the same package.

Sagar Rohankar
Ranch Hand

Joined: Feb 19, 2008
Posts: 2902
    
    1

Then find out why "here 3" is not getting logged out, find out why 'JobDetail' instance is not getting created. Simply try/catch the block and use System.out. statements to print.
Justin Howard
Ranch Hand

Joined: Feb 19, 2009
Posts: 162
Hi Sagar,

I do have a try/catch block. I did not paste that part of the code in the forum.
Earlier in the post I have posted what was coming up in the logs.

Thanks
Sagar Rohankar
Ranch Hand

Joined: Feb 19, 2008
Posts: 2902
    
    1

Its hard to say then, neither logs nor any exception trace to point out the problem.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Quartz Sheduler not executing