Meaningless Drivel is fun!*
The moose likes Servlets and the fly likes Problem in Deployment Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "Problem in Deployment" Watch "Problem in Deployment" New topic
Author

Problem in Deployment

Vishal Srivastav
Ranch Hand

Joined: Nov 29, 2008
Posts: 46

Dear Friends,

I am having problem running a simple Login application using the Sun Application Server 8.2. I am describing my problem here and I need your help in the matter.

The code of the files are as follows -

index.html



LoginServlet.java



I am using deploytool for deployment provided along with the Sun App Server with the following values -

Context Root - LoginApp
Aliases - /Login.do

The application is getting deployed successfully. But when I am trying to run the application and sending the data, I am getting two errors -

On the 1st request -



On the 2nd request -



I am not able to find where the problem is arising. Please help me as I am in urgent need.

Thanks All.


Vishal Srivastava, Software Engineer (Android), Paradigm Creatives
SCJP 5, SCWCD 5 - http://in.linkedin.com/in/srivastavavishal
Anuj Prashar
Ranch Hand

Joined: Apr 15, 2008
Posts: 99

Make your servlet class public instead of default access.


SCJP 5,SCWCD 5, RHCT
 
wood burning stoves
 
subject: Problem in Deployment
 
Similar Threads
Integer vs. String
java.sql.SQLException: Stream has already been closed
Getting error: Bad version number in .class file
EJB3 Error Server problem or code?
EJB 2 + Sql Server 2000