aspose file tools*
The moose likes Struts and the fly likes Struts in Websphere Application Developer 5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts in Websphere Application Developer 5" Watch "Struts in Websphere Application Developer 5" New topic
Author

Struts in Websphere Application Developer 5

Treva Willett
Greenhorn

Joined: Apr 07, 2003
Posts: 2
I have a application using struts that works fine in Websphere 4, but I went to version 5 and now I am having a problem in my xml files.
<!DOCTYPE struts-config PUBLIC
"-//Apache Software Foundation//DTD Struts Configuration 1.1//EN"
"http://jakarta.apache.org/struts/dtds/struts-config_1_1.dtd">
I receive an error on the http line, but there is no description that goes along with the error. I do not know if I missed something going from version 4 to version 5. Any help would be appreciated.
Santiago Arriaga
Greenhorn

Joined: Jan 14, 2003
Posts: 4
Are there any errors in the logs ?
I also updated an application from WSAD 4 to WSAD 5 testing with Tomcat 4 Test Environment, and the only issue I had was that I had to use J2SE 1.4 for the java SDK. Other than that, all ran fine.
Treva Willett
Greenhorn

Joined: Apr 07, 2003
Posts: 2
I got my above problem worked out, but now I have the following errors in my tasks window:
JSP Translate: End of Content reached while more parsing required: tag nesting error?.
Here is my JSP:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean"%>
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html"%>
<%@ taglib uri="/WEB-INF/struts-logic.tld" prefix="logic"%>
<html:html locale="true">
<HEAD>
<TITLE>Welcome</TITLE>
<html:base/>
<META name="GENERATOR" content="IBM WebSphere Studio">
</HEAD>
<BODY>
<P><FONT color="#000099" size="+2" face="Arial"><bean:message key="welcome.heading"/></FONT><BR>
<BR>
<FONT face="Arial"><bean:message key="welcome.message"/></FONT></P>
<html:errors/>
<html:form action="/LogonSubmit" focus="username">
<TABLE border="0" width="100%">
<TBODY>
<TR>
<TH align="right"><FONT face="Arial" size="-1">Mainframe User Id:</FONT></TH>
<TD align="left"><html:text property="username"/></TD>
</TR>
<TR>
<TH align="right"><FONT face="Arial" size="-1">Mainframe Password:</FONT></TH>
<TD align="left"><html assword property="password"/></TD>
</TR>
<TR>
<TD align="right"><html:submit/></TD>
<TD align="left"><html:reset/></TD>
</TR>
</TBODY>
</TABLE>
</html:form>
</BODY>
Mark Gowdy
Greenhorn

Joined: May 14, 2001
Posts: 28
Hi,
It means you haven't closed all tags properly. Take a look at <html:html>.
Cheers
Mark
Sean Gildea
Ranch Hand

Joined: Jul 01, 2004
Posts: 81
Hi,
It means you haven't closed all tags properly. Take a look at <html:html>.

Cheers

Mark


Mark was right, I just had this error

before:
<c ut value="${IMBPOs}">

after:
<c ut value="${IMBPOs}"/>

problem fixed! task error gone after saving!


SCJD, SCBCD, SCJP
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Struts in Websphere Application Developer 5
 
Similar Threads
cant find websphere 4
struts error
Error in validation.xml, validator-rules.xml, hibernate.cfg.xml file etc
java.lang.Exception: Attempted to use a 5.0 DataSource outside of a 2.3 servlet
There is no Action mapped for action name showLogin. - [unknown location]