wood burning stoves*
The moose likes BEA/Weblogic and the fly likes weblogic startup problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "weblogic startup problem" Watch "weblogic startup problem" New topic
Author

weblogic startup problem

ajse ruku
Ranch Hand

Joined: May 06, 2005
Posts: 193
Hi ,

I get following error when i try to access my application deployed on weblogic server.

Unable to lookup the JNDI name abc.xyz
javax.naming.CommunicationException [Root exception is java.net.ConnectException:Bootstrap to IP_Address_1:7001 failed. It is likely that the remote side declared peer gone on this JVM]

I have also seen below log statements after weblogic starts.

<HostName: XYZ.com, maps to multiple IP addresses:IP_Address_1,IP_Address_2>
<Thread "ListenThread.Default" listening on port 7001, ip address IP_Address_1>

I have entered IP_Address_1 as listen address in my weblogic config.

Please let me know if i am missing something.

regards,
Ajse
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6657
    
    5

Are you able to reach weblogic using both IP addresses ? Is the JNDI name bound correctly ?


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
ajse ruku
Ranch Hand

Joined: May 06, 2005
Posts: 193
Thanks Deepak for you inputs.

I can reach weblogic through IP_Address_1 which i have mentioned in config.xml as listen address.
JNDI name is correct.

regards,
Ajse
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6657
    
    5

ajse roy wrote:Thanks Deepak for you inputs.

I can reach weblogic through IP_Address_1 which i have mentioned in config.xml as listen address.
JNDI name is correct.

regards,
Ajse


Perhaps the context is closed before you do the lookup ? That is what this message seems to indicate. Can you post some code and at which line the code fails ?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: weblogic startup problem
 
Similar Threads
Help Please...unable to start the managed server
servers are using the same listen address and port???
WLSERVER ANT TASK
WebLogic 8.1 question
Resolving or Replacing localhost with IP Address - weblogic 10.3