File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse Dynamic Web Project: Java compiler level does not match the installed Java Project facet Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse Dynamic Web Project: Java compiler level does not match the installed Java Project facet" Watch "Eclipse Dynamic Web Project: Java compiler level does not match the installed Java Project facet" New topic
Author

Eclipse Dynamic Web Project: Java compiler level does not match the installed Java Project facet

Paul Santa Maria
Ranch Hand

Joined: Feb 24, 2004
Posts: 236
Hi -

I've created a new Dynamic Web Project in Eclipse. I need to set the JDK compliance level to "1.5". But I get this error:

Java compiler level does not match the version of the installed Java project facet


Q: Is there any way to figure out WHICH facet it's complaining about, so I can fix it?

Thank you in advance .. PSM


Paul M. Santa Maria, SCJP
Paul Santa Maria
Ranch Hand

Joined: Feb 24, 2004
Posts: 236
QUESTION ANSWERED:

There is a "Project Facets" section under the project's properties. I just changed Java "version" to 5.0, and things are working



[Thumbnail for ss_01.jpg]

Gemini Moses
Ranch Hand

Joined: Jan 04, 2001
Posts: 245
Paul,

I am getting same error that you were.

However , For Project facets
Java I have only 1.4 or 1.3 in the dropdown.

How do I get 1.5 populated here so I can select it?

Thanks!

Gemini Moses
Ranch Hand

Joined: Jan 04, 2001
Posts: 245
I got it. My runtime was WAS6.0 hence Java 5 was not shown in dropdown
Mr. Ram
Greenhorn

Joined: Jul 12, 2006
Posts: 9
The issue has been resolved.
Haifeng Jiang
Ranch Hand

Joined: Dec 14, 2008
Posts: 42
Paul Santa Maria wrote:QUESTION ANSWERED:

There is a "Project Facets" section under the project's properties. I just changed Java "version" to 5.0, and things are working


fixed after looking your solution. thanks


Thinking a lot. Gaining a lot.
Maki Jav
Ranch Hand

Joined: May 09, 2002
Posts: 435
Thank you,

It has helped me too today, 5 years after you posted.


Thanks


Maki Jav


Help gets you when you need it!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse Dynamic Web Project: Java compiler level does not match the installed Java Project facet
 
Similar Threads
iRAD 7 - WAS 6.1 - jdk 1.4.2 compatibility
Project facet Java 5.0 is not supported by target runtime Apache Tomcat v5.5
Unsupported major.minor version 50.0
Project facet Java 6.0 is not supported by target runtime WebSphere Application Server v6.1.
struts2 newbie: (1) how to validate without xml & (2) how to have a dispatchAction?