aspose file tools*
The moose likes Web Services and the fly likes Webservice using axis2 1.0 and rampart Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Webservice using axis2 1.0 and rampart" Watch "Webservice using axis2 1.0 and rampart" New topic
Author

Webservice using axis2 1.0 and rampart

vicky soni
Greenhorn

Joined: Oct 08, 2009
Posts: 2
Hi,

I am getting following exceptions while running my webapplication using weblogic 10.1. It is throwing the exception when it is calling the webservice.

java.lang.NoClassDefFoundError: org.apache.ws.security.handler.WSHandler
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:242)
at org.apache.axis2.deployment.util.Utils.getHandlerClass(Utils.java:182)
at org.apache.axis2.deployment.util.Utils.addFlowHandlers(Utils.java:60)
at org.apache.axis2.deployment.DeploymentEngine.addNewModule(DeploymentEngine.java:337)
at org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine.java:690)
at org.apache.axis2.deployment.RepositoryListener.init(RepositoryListener.java:165)
at org.apache.axis2.deployment.RepositoryListener.(RepositoryListener.java:53)
at org.apache.axis2.deployment.DeploymentEngine.loadRepository(DeploymentEngine.java:107)
at org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:120)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:38)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:90)
at org.apache.axis2.DocumentServiceAdapterServiceStub.(Unknown Source)
at com.genworth.commarchive.bizlogic.ContentSearchService.getAllSearchResults(ContentSearchService.java:349)
at com.genworth.commarchive.bizlogic.ContentSearchService.search(ContentSearchService.java:35)
at com.genworth.commarchive.action.HomeAction.execute(HomeAction.java:133)
at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:419)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:224)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1194)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:226)
at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:124)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:175)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3395)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(Unknown Source)
at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2140)
at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2046)
at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1366)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:200)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:172)


I have wss4j and all other required jars in my classpath. could anyone can help me out here please.

Thanks in advance.

-Vicky
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 39576
    
  27
That class is in a file called "wss4j-1.5.8.jar", or having some other version number. Make sure that file is present and usable.


Ping & DNS - updated with new look and Ping home screen widget
vicky soni
Greenhorn

Joined: Oct 08, 2009
Posts: 2
Thanks for the reply, I have wss4j-1.5.1.jar in my classpath. Earlier my application was working fine in weblogic 10.0. But after we upgrade weblogic from weblogic 10.0 to weblogic 10.1, it is throwing these classnotfound expection. Thanks in advance!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Webservice using axis2 1.0 and rampart
 
Similar Threads
com.oroad.stxx.transform.TransformerException: Unable to retrieve template null
Dynamic Form Elements - Exception
Does anyone know what this error means?
Weblogic 10.3 FastSwap + Struts 1.X
The addressing-1.41.mar module, which is not valid, caused org.apache.axis2.handlers.addressing.Addr