aspose file tools
The moose likes Junior/Associate Certification (SCJA,OCAJ 5/6/8) and the fly likes java.lang.UnsupportedClassVersionError Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Head First Android this week in the Android forum!
JavaRanch » Java Forums » Certification » Junior/Associate Certification (SCJA,OCAJ 5/6/8)
Bookmark "java.lang.UnsupportedClassVersionError" Watch "java.lang.UnsupportedClassVersionError" New topic
Author

java.lang.UnsupportedClassVersionError

Prashanth Nellutla
Greenhorn

Joined: Oct 08, 2009
Posts: 8
Hi I'm getting this error when tried to run my first java class. Could someone pelase guide me.

Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version n
umber in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)

Prashanth Nellutla
Greenhorn

Joined: Oct 08, 2009
Posts: 8
All,

I resolved this by uninstalling the previous version.
 
wood burning stoves
 
subject: java.lang.UnsupportedClassVersionError
 
It's not a secret anymore!