aspose file tools*
The moose likes BEA/Weblogic and the fly likes Getting error while doing install in Weblogic 10.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Getting error while doing install in Weblogic 10.0" Watch "Getting error while doing install in Weblogic 10.0" New topic
Author

Getting error while doing install in Weblogic 10.0

lakshmi desai
Greenhorn

Joined: Feb 28, 2008
Posts: 16
Hi,

I am getting this error while doing install in WebLogic 10.0. However I could install/deploy the application before and the application was up and running. The only change I made was, initially I was working with Eclipse 3.2.x,MyEclipse 5.5.1 and Weblogic 10.0 -> It worked fine and I could access the app. Now after I installed the newer version of myeclipse Eclipse 3.3.x with MyEclipse 6.6(the WebLogic is the same) and try to install the project, it gives me this error. Did anybody run into this issue before?Any sugsestions? I think there must be some problem with the WebLogic console and not with my app. I tried mutliple times installing, all of them resulted in the same error. I have tried with both .ear and .war files.

Error opening /jsp/app/install/Identity.jsp.
The source of this error is javax.servlet.ServletException: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The reference to entity "war" must end with the ';' delimiter. at weblogic.servlet.jsp.PageContextImpl.handlePageException(PageContextImpl.java:420) at jsp_servlet._jsp._app._install.__identity._jspService(__identity.java:163) at weblogic.servlet.jsp.JspBase.service(JspBase.java:34) at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:226) at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:124) at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283) at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:175) at weblogic.servlet.internal.RequestDispatcherImpl.invokeServlet(RequestDispatcherImpl.java:528) at weblogic.servlet.internal.RequestDispatcherImpl.include(RequestDispatcherImpl.java:454) at org.apache.beehive.netui.pageflow.scoping.internal.ScopedRequestDispatcher.include(ScopedRequestDispatcher.java:119) at com.bea.netuix.servlets.controls.content.JspContent.beginRender(JspContent.java:551) at com.bea.netuix.servlets.controls.content.NetuiContent.beginRender(NetuiContent.java:363) at com.bea.netuix.nf.ControlLifecycle$7.visit(ControlLifecycle.java:483) at com.bea.netuix.nf.ControlTreeWalker.walkRecursiveRender(ControlTreeWalker.java:518) at com.bea.netuix.nf.ControlTreeWalker.walkRecursiveRender(ControlTreeWalker.java:529) at com.bea.netuix.nf.ControlTreeWalker.walkRecursiveRender(ControlTreeWalker.java:529) at com.bea.netuix.nf.ControlTreeWalker.walkRecursiveRender(ControlTreeWalker.java:529) at com.bea.netuix.nf.ControlTreeWalker.walkRecursiveRender(ControlTreeWalker.java:529) at com.bea.netuix.nf.ControlTreeWalker.walkRecursiveRender(ControlTreeWalker.java:529) at com.bea.netuix.nf.ControlTreeWalker.walk(ControlTreeWalker.java:220) at com.bea.netuix.nf.Lifecycle.processLifecycles(Lifecycle.java:375) at com.bea.netuix.nf.Lifecycle.processLifecycles(Lifecycle.java:341) at com.bea.netuix.nf.Lifecycle.processLifecycles(Lifecycle.java:332) at com.bea.netuix.nf.Lifecycle.run(Lifecycle.java:306) at com.bea.netuix.nf.UIControl.render(UIControl.java:578) at com.bea.netuix.servlets.controls.PresentationContext.render(PresentationContext.java:482) at com.bea.netuix.servlets.util.RenderToolkit.renderChild(RenderToolkit.java:146) at com.bea.netuix.servlets.jsp.taglib.RenderChild.doStartTag(RenderChild.java:62) at jsp_servlet._framework._skeletons._default.__gridlayout._jspService(__gridlayout.java:285) at weblogic.servlet.jsp.JspBase.service(JspBase.java:34) at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:226) at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:124) at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283) at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:175) at weblogic.servlet.internal.RequestDispatcherImpl.invokeServlet(RequestDispatcherImpl.java:528) at weblogic.servlet.internal.RequestDispatcherImpl.include(RequestDispatcherImpl.java:454) at com.bea.netuix.servlets.controls.application.laf.JspTools.renderJsp(JspTools.java:123) at com.bea.netuix.servlets.controls.application.laf.JspControlRenderer.beginRender(JspControlRenderer.java:72) at
lakshmi desai
Greenhorn

Joined: Feb 28, 2008
Posts: 16
Hi,

I got this resolved. For those of you interested, this is what happened..Its so strange but this has happened just now...
I first had my lis.ear in C:\QW\ear&war folder, tried install in wl 10.0, gave me this error and I kinda guessed may be "The reference to entity "war" must end with the ';' delimiter" is looking at the folder name "ear&war" and taking that and expecting something in there, thats why its giving me that error. So I put my lis.ear in C:\QW, got rid of the "ear&war" folder and also tried having my lis.ear in C:\QW\ear_war, worked perfectly fine. I dont know exactly whats happening inside....if someone could throw some light on this..
Thanks for reading...

Error opening /jsp/app/install/Identity.jsp.
The source of this error is javax.servlet.ServletException: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The reference to entity "war" must end with the ';' delimiter. at weblogic.servlet.jsp.PageContextImpl.handlePageException(PageContextImpl.java:420) at jsp_servlet._jsp._app._install.__identity._jspService(__identity.java:163) at weblogic.servlet.jsp.JspBase.service(JspBase.java:34) at
and I kinda guessed may be
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

This looks like a problem with a XSLT that you are running instead of with the app. Try running this XSL file against an XML outside weblogic. It should throw the same error


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Getting error while doing install in Weblogic 10.0