File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Ant, Maven and Other Build Tools and the fly likes java.lang.VerifyError Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "java.lang.VerifyError" Watch "java.lang.VerifyError" New topic


Jyotsna Pai

Joined: Aug 07, 2009
Posts: 18
Hi there,

Can anyone help me with this as I am new to Ant build.
I am getting the java.lang.VerifyError when I try to run my build with a target environment.

I looked at a similar question earlier, and tried changing the JDK to a version 1.3.1_10, it did not work. The build.xml is as follows -

I am using Oracle JDeveloper. The JDK version is 1.4.2_03 and the classpath is set to:

Thanks. Any help much appreciated.

SCJP (73%)
SCWCD (85%)
David Newton

Joined: Sep 29, 2008
Posts: 12617

What version of Ant?
Jyotsna Pai

Joined: Aug 07, 2009
Posts: 18
Hi David,

Thanks for your reply!
I was using ant.jar of a version 1.3 on Windows XP and WinCVS 1.2 for source control.
The IDE used is Oracle JDeveloper version

I was trying to resolve this error and in the process changed my ant.jar to version 1.5.1.
Now instead of VerifyError, I am getting "Unable to execute Ant" with the following error details -

My Path, Classpath and JAVA_HOME details are -

Incidentally which ever version of ant.jar I use, whether version 1.3 or version 1.5.1 , I am getting the same error - Cannot execute Ant - CreateProcess Exception as above.

Thanks again.

Jyotsna Pai
Jyotsna Pai

Joined: Aug 07, 2009
Posts: 18
I landed up resolving the CreateProcess exception.
It seems it was in relation to the classpath and path.

But somehow its reverted back to the VerifyError exception.
My Path is -

and my classpath is

The ant.jar has to be the same as used in production, which is of version 1.3
Platform - Windows XP
Source control - WinCVS 1.2
IDE - JDeveloper version
Build.xml is same as in my first email.

Please advise me on resolving this error. I have to use ant.jar of version 1.3.
I agree. Here's the link:
subject: java.lang.VerifyError
It's not a secret anymore!