wood burning stoves 2.0*
The moose likes Tomcat and the fly likes unable to connect to tomact6.0 server from a different computer on the network Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "unable to connect to tomact6.0 server from a different computer on the network" Watch "unable to connect to tomact6.0 server from a different computer on the network" New topic
Author

unable to connect to tomact6.0 server from a different computer on the network

chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

hi all of you. My name is chaitanya. recently i discovered a problem while using tomcat6.0 web server.
previously i used apache geronimo application server. i was able to connect to the server from a different computer on the network while using geronimo server.
now i migrated to apache tomcat6.0 server. when i am trying to connect to the server using a different computer on the network, i am un able to connect to it.


I thought that there is a problem in the network connection. I checked the network connection its fine. I once again installed geronimo server and tried to connect to the server. I was connected. therefore i discovered that there is no problem with the network connection.

once again i tried to connect to tomcat server from different computer. it is not getting connected.

tomcat is running on 8080 port. when i am trying to connect to it from local system as http://localhost:8080/App it is getting connected. when i am trying to connect to it from different computer as http://<my_ipaddress>:8080/App it is not getting connected.

please anybody help me in this regard.


Love all, trust a few, do wrong to none.
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10167
    
    8

Does the tomcat machine have a firewall which is blocking 8080?
I have not used geronimo. Did it also run on 8080?


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

I am able to reach the machine using geronimo server. but with tomcat i am unable to reach the machine
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10167
    
    8

Did you check the firewall for blocked ports?
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

i dont know about it. please sir tell me how to check.
Swastik Dey
Rancher

Joined: Jan 08, 2009
Posts: 1449
    
    6

from command prompt type the following command

telnet <ipaddress>:8080

and see what response you get, if its a failed response means that particular port is blocked.


Swastik
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

sir i have done like this

telnet 192.168.0.144:8080

i got the following message

Connecting to 192.168.0.144:8080...Could not open connection to the host, on port 23: Connect failed
Swastik Dey
Rancher

Joined: Jan 08, 2009
Posts: 1449
    
    6

It means the port 8080 is blocked through some firewall settings. From network properties you need to disable the firewall or you can change the port number of tomcat server.
Smitesh Shinde
Ranch Hand

Joined: Feb 16, 2008
Posts: 45

Anusha,
Run telnet command as
telnet ipaddress 8080
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

i have done sir.
telnet ipaddress 8080. again i got the same error message
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

i have changed the port number from 8080 to 8081. but i am unable to access the server from different machine
i have turned off the windows fire walls in sever machine. now i am able to connect to it through a client system. but this is too risky process. the server machine will be at risk. is there any other way to do this one.
please anybody guide me
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10167
    
    8

You need not bring the whole firewall down. Just open the required port.
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

sir i dont know how to open the required port please help me.
samir singha
Greenhorn

Joined: Mar 17, 2008
Posts: 23
Which OS you are using?
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10167
    
    8

Its Windows.
anusha chaitanya wrote:
......i have turned off the windows fire walls in sever machine


anusha chaitanya wrote:
sir i dont know how to open the required port please help me.


Come on anusha chaitanya. Dont you have net access? Dont you know how to Google? http://faq.javaranch.com/java/SearchFirst
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

sir i have searched in web, i have found the related information but it is not working.

in windows web site i have found some information.
there it was said to- go to firewalls settings>exceptions>add port> then open the 80 port. i have done as it was described. but it is not working sir.

is there any other idea.
Misha Ver
Ranch Hand

Joined: Mar 03, 2008
Posts: 470
anusha chaitanya wrote:then open the 80 port


As I remember you have an issue with port 8080 not 80. Am I correct?
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

yes sir, i have problem with port 8080
Misha Ver
Ranch Hand

Joined: Mar 03, 2008
Posts: 470
In this case you should open port 8080, not 80 as you described above
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

but in the forum it was said that you need not enter 8080. just enter 80. k sir i will try that one olso and i soon soon inform you
chaitanya karthikk
Ranch Hand

Joined: Sep 15, 2009
Posts: 800

hi everybody, thanks for all of you for being with me and suggesting me, the problem is solved...i turned off the windows firewall settings.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: unable to connect to tomact6.0 server from a different computer on the network
 
Similar Threads
Unable to connect
HELP - Can't get Tomcat Working!!
tomcat server is not connecting to db2 database or any other database
RMI marshalling arguments error
Help - Can't get Servlets working!