• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

List values are not bind with text fields

 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi guys,

I have a problem with my project.I'm using struts2 EJB3,oracle top link and a oracle data base.
I created a view by using four data base tables and then created a entity class for that view.
what I want to do is retrieve data by using that view and display them in a jsp page.
I retrieved data from a list by using that above view.
then when I'm going to show that data in my jsp page they are not appear in the jsp page

below is my jsp code;and "searchClienGrouptList" is my list name which I derived by using a query. my view's name is "clientView"






when I'm going to load data to the jsp page below page appears.
123.JPG
[Thumbnail for 123.JPG]
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64959
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please be sure to ask Struts questions in the Struts forum. I have moved this post there for you.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Without the action code it will be essentially impossible to help.

The name of your list in the iterator tag, however, is suspicious: "searchClienGrouptList". Is that a typo?
 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
here is my action code



I'm using a method called searchClient in the session bean to retrieve data from the database
if you want that code as well please inform
thanks
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's a *really* bad idea to propagate spelling errors like that.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does the resulting empty table show the correct number of rows? Have you confirmed the data is being returned correctly? Is that line of code *really* that long?! 800+ chars is too long for a single line of code.
 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes I checked and double checked.I know there are spelling mistakes I changed those words for check whether it's working .
there are 31 records in the database view.and also same number of rows are appeared in the table .
I'm sending all the codes again
please help I'm stuck with this problem than 5 days.










THANKS FOR HELPING...
123.JPG
[Thumbnail for 123.JPG]
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And the bean code? And the action properties?
 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
this is the bean code





what do you mean by action properties
is it my action's getters and setters??
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's not the bean code, that's the code that retrieves thelist.
 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks guys..
the problem was solved
there was a little mistake

thanks lot for helping ...
THANKS...
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic