File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Struts and the fly likes JADE framework and JSTL breaks! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "JADE framework and JSTL breaks!" Watch "JADE framework and JSTL breaks!" New topic

JADE framework and JSTL breaks!


Joined: Jun 26, 2003
Posts: 6
I'm developing in WSAD using the EAD4J JADE framework. We are trying to install the JSP Standard Tag Library (JSTL). I downloaded Standard 1.03 from Jakarta and copied all the jar files into my webApplication/WEB-INF/lib directory.
When I go into WSAD, refresh from local, rebuild and start the server, the application dies. I can still get to the entry page which is just HTML but as soon as I try to log in, my login servlet dies and gives a ClassCastException (see below)
Anyone out there ever worked with JADE and had a similar problem? Could there be naming conflicts? I've tried going through debug, but i don't have access to the source code that is throwing the exception. Are they just plain incompatible? We don't appear to have the JADE tag libs installed so I don't know why there would be a conflict. Here's my exception.
java.lang.ClassCastException: at at javax.rmi.PortableRemoteObject.narrow( at at at at at at at at
any help would be appreciated.
I agree. Here's the link:
subject: JADE framework and JSTL breaks!
jQuery in Action, 3rd edition