• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

RC1 -> 1.1 final datasource probs

 
Paul Woods
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have an app that I just upgraded to 1.1 final from RC1, removing the old jars, installing the new ones, and I am having serious issues getting it to even start. It worked before.
I have updated the data-source portion of the struts-config to reflect a move from the deprecated genericdatasource to basicdatasource.
My datasource part of the struts-config.xml file is:

The exception I get when loading the first page (which does not require data access), is:

I'm stumped. I downloaded 1.1 final and installed the Jars, are there others from commons I should install as well? Is there an error in the config above?
Thank you for any pointers,
Paul
 
Anonymous
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it seems that you missed one jar. This is no configuration issue but a class loader issue.
He simply cannot find the class in any of the jars you put to your applications class path.
olli
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic