aspose file tools*
The moose likes Struts and the fly likes servlet.log not working in struts/tomcat environment Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of JavaScript Promises Essentials this week in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "servlet.log not working in struts/tomcat environment" Watch "servlet.log not working in struts/tomcat environment" New topic
Author

servlet.log not working in struts/tomcat environment

Nadine McKenzie
Ranch Hand

Joined: Feb 15, 2002
Posts: 53
I can't figure out how to send logging info to the tomcat log file.
I *think* Tomcat's log is specified in tomcat/conf/server.xml and have modified the following Logger element:
<Logger className="org.apache.catalina.logger.FileLogger"
prefix="realationships_server" suffix=".log"
timestamp="false" verbosity="4"/>
When peeking at the log file in the tomcat/logs dir, my servlet.log info is not appearing.
The web.xml file has the following entry:
<servlet>
<servlet-name>action</servlet-name>
<servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
<init-param>
<param-name>debug</param-name>
<param-value>4</param-value>
</init-param>
<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
<init-param>
<param-name>application</param-name>
<param-value>ApplicationResources</param-value>
</init-param>
<load-on-startup>1</load-on-startup>
</servlet>
Could it be that servlet.log(...) is not the correct api call to make within the struts framework (i.e my action class and action form) or is my environment incorrectly set up.
Any help would be much appreciated.


Nadine -SCJP, SCWCD, SCBCD
Nadine McKenzie
Ranch Hand

Joined: Feb 15, 2002
Posts: 53
Solution found! I added the jars files to the lib dir from a struts application that was working and archived the old ones. Works fine now.
Reason? Unknown - what irks me is that no logging info (servlet.log) was being sent to the tomcat logger and no exceptions were being reported. I was getting a blank xxx.do page appearing.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: servlet.log not working in struts/tomcat environment