This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Server starts but page can't display (JBoss AS 5.1.0.GA) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Server starts but page can Watch "Server starts but page can New topic
Author

Server starts but page can't display (JBoss AS 5.1.0.GA)

Fabiano Campos
Greenhorn

Joined: Oct 20, 2009
Posts: 3
Hello.
I installed JBoss in a Red Hat Enterprise and I can start JBoss AS without errors, but when I try to access: http://localhost:8080/ web-console and jmx-console gives an error page.
Any tips? Need to start some other service?

Thanks


Fabiano Campos
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

Fabiano, welcome to Java Ranch!

jmx-console gives an error page

What error page? Details, please.

Also, are you accessing web-console or jmx-console? Your post is inconsistent on that point.

It might also help if you posted the full console log (not the server.log file!), starting with the command line you entered to run JBoss AS.


JBoss In Action
Fabiano Campos
Greenhorn

Joined: Oct 20, 2009
Posts: 3
Ok, Peter. I'm so sorry!

Don't open any of them. It's as if the server is stopped, but isn't and has no error in the console. See below:



Fabiano Campos
Greenhorn

Joined: Oct 20, 2009
Posts: 3
Hello, I found that when executed on the server (localhost: 8080) the page opened. But he tried not by IP. Was a parameter in the bin (jboss_init_redhat) was necessary to change the IP 127.0.0.0 to the server. Now is functioning normally.

Thanks,
 
Don't get me started about those stupid light bulbs.
 
subject: Server starts but page can't display (JBoss AS 5.1.0.GA)