wood burning stoves*
The moose likes BEA/Weblogic and the fly likes Issue calling a stored procedure from Weblogic 8.1 workshop project Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Issue calling a stored procedure from Weblogic 8.1 workshop project" Watch "Issue calling a stored procedure from Weblogic 8.1 workshop project" New topic
Author

Issue calling a stored procedure from Weblogic 8.1 workshop project

Ash Kondhalkar
Ranch Hand

Joined: Jun 14, 2006
Posts: 43
Hi

I have one stored procedure, which takes one input parameter and second is output parameter. When I call the stored procedure using DAO design pattern inside weblogic 8.1 workshop proejct, it is failing and giving me below exception,

"Incorrect parameter bindings for stored procedure call.Check your bindings against the stored procedure parameters."

Surprisingly, when I call the same stored procedure using a stand alone java class(inside which I am creating a database connection, callable statement, setting the in parameter and the registering the output parameter and executing the callable statement) it is working fine and giving me the output.

Thanks & Regards
Ashwin
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

Please mention

Database name
Database version
Driver version
Driver name
Driver type
XA Vs Non XA connection
If Non XA what TX does it use
What is the TX setting of the stored procedure. Chained Vs unchained.


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
Ash Kondhalkar
Ranch Hand

Joined: Jun 14, 2006
Posts: 43
Deepak,

It worked. Thank you for asking me below questions. I found that in standalone java class I was using Oracle's database driver while in the weblogic 8.1 datasource I was using BEA weblogic's database driver class. After I changed by datasource driver class to Oracle driver classs it worked.

Thanks a lot once again.
Regards
Ashwin
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

Thank you for sharing the solution. There are known problems with some driver types for Oracle / Sybase.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Issue calling a stored procedure from Weblogic 8.1 workshop project