aspose file tools*
The moose likes Struts and the fly likes No Error Message But A Blank Page Is Displayed!!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "No Error Message But A Blank Page Is Displayed!!!" Watch "No Error Message But A Blank Page Is Displayed!!!" New topic
Author

No Error Message But A Blank Page Is Displayed!!!

JiaPei Jen
Ranch Hand

Joined: Nov 19, 2000
Posts: 1309
I am experimenting a basic application - logon. I got the first two screens working without problem. However, the third screen displays a blank page (no error message). I am having a very difficult time to figure out the problem; henceforth, seeking help. Here is the history of my application:
1. http://localhost:8080/LogonPractice/index.jsp (no problem and I clicked on "Sign in")
2. http://localhost:8080/LogonPractice/Logon.do;jsessionid=170B50E4D8E07EE36290E98342E8BF9C (no problem and the screen asked for username and password. I filled out the information and clicked on "Submit")
3. http://localhost:8080/LogonPractice/LogonSubmit.do (displayed a blank page)
The Tomcat log file shows the following (no error message at all):

2003-09-29 23:29:26 action: Processing a GET for /Logon
2003-09-29 23:29:26 action: Looking for Action instance for class org.apache.struts.actions.ForwardAction
2003-09-29 23:29:26 action: Double checking for Action instance already there
2003-09-29 23:29:26 action: Creating new Action instance
2003-09-29 23:29:35 action: Processing a POST for /LogonSubmit
2003-09-29 23:29:35 action: Looking for ActionForm bean under attribute 'logonForm'
2003-09-29 23:29:35 action: Creating new ActionForm instance of class 'org.apache.artimus.logon.LogonForm'
2003-09-29 23:29:35 action: Storing instance under attribute 'logonForm' in scope 'request'
2003-09-29 23:29:35 action: Populating bean properties from this request
2003-09-29 23:29:35 action: Validating input form properties
2003-09-29 23:29:35 action: No errors detected, accepting input
2003-09-29 23:29:35 action: Looking for Action instance for class org.apache.artimus.logon.LogonAction
2003-09-29 23:29:35 action: Double checking for Action instance already there
2003-09-29 23:29:35 action: Creating new Action instance

in my struts-config.xml, I have:

and my LogonAction.java is:

The Constants.class is in the ApplicationRoot/WEB-INF/classes/org/apache/artimus/lang directory. And I have

My Welcome.jsp in the ApplicationRoot/signin folder looks like:

[ September 29, 2003: Message edited by: JiaPei Jen ]
satish pune
Ranch Hand

Joined: Sep 04, 2003
Posts: 44
Have you specified ApplicationResources.properties file in web.xml ?
Is there an entry for : "error.logon.invalid" in this file ?
-satish
JiaPei Jen
Ranch Hand

Joined: Nov 19, 2000
Posts: 1309
Yes, I have the code shown below in my web.xml file:

and the application.properties is in the resources folder. And I have

in the application.properties file.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: No Error Message But A Blank Page Is Displayed!!!
 
Similar Threads
Struts Validator not validating on the server-side
Problem reg. Delete Operation in my struts application
Unable to Call Action Servlet when datasource elememt in kept struts-config.xml
Blank page returned from ActionForm
Validate() method of ActionForm