aspose file tools*
The moose likes Other Open Source Projects and the fly likes Pentaho 3.5 for java developers + problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "Pentaho 3.5 for java developers + problem" Watch "Pentaho 3.5 for java developers + problem" New topic
Author

Pentaho 3.5 for java developers + problem

matias casal
Ranch Hand

Joined: Oct 18, 2009
Posts: 61
Hello!
I have read de book pentaho 3.5 for java developers, and it is very good. However, I am having a problem trying to include my reports in a web application.
I followed step by step everything mentioned in the book, and this problem its shown

Estado HTTP 404 - /report/

type Informe de estado

mensaje /report/

descripción El recurso requerido (/report/) no está disponible.

Description: The resource required(/report/) is not available

I will describe what i have done


First of all, I imported all the libraries from pentaho report designer 3.5.

Then I created an index.html.


Then, i build my java servlet


Fourtly, I created a folder in the web-inf directory called data, and there I put my report reporte1.prpt

Finally I wrote my web.xml file


When I run my application, the index page is shown, and the error ocurrs when I click on Generate PDF Report link
I noticed that the link goes to /report/, but there is no folder o file called report.
How can I solve this problem?
Any suggestion?

Thank You
Will Gorman
author
Ranch Hand

Joined: Sep 12, 2009
Posts: 37
Hello, you should either map your servlet url to report, or change the link in your HTML page to your defined controller/ServletPrimero url.

Glad you liked the book! Good luck!

Will


Pentaho Reporting 3.5 for Java Developers
matias casal
Ranch Hand

Joined: Oct 18, 2009
Posts: 61
Yes, it is what i ve done now
My code is


But with that and error 500 happens saying that cant find the resource report.
However, I tried to create a new folder name report, and there i put the files and folders from de folder report-viewer in the biserver 3.5
The error 500 and 400 dont appear now, but when i click on view pdf report, after loading a seconds, an error label from pentaho appears ( without a name).
I think that i am near the solution, but there is something i m missing

my new html is


Thank you for answering
If you know how to solve my problem, you are welcome
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Pentaho 3.5 for java developers + problem