Meaningless Drivel is fun!*
The moose likes Servlets and the fly likes javax.naming.CannotProceedException; remaining name Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "javax.naming.CannotProceedException; remaining name" Watch "javax.naming.CannotProceedException; remaining name" New topic
Author

javax.naming.CannotProceedException; remaining name

Juan Malle
Greenhorn

Joined: Nov 11, 2009
Posts: 2
Hi, im trying to acces an EJB entity from a servlet.
The EJB is using Persistance, and MySQL
Im using Jboss 5.1.0.GA as Container, and i can see the EJB correctly deployed into

********** From the jboss console manager ****************************************************

Global JNDI Namespace

+- UserTransactionSessionFactory (proxy: $Proxy230 implements interface org.jboss.tm.usertx.interfaces.UserTransactionSessionFactory)
...
+- LibroBean (class: org.jnp.interfaces.NamingContext)
| +- remote-ve.ekabod.lib.LibroBeanRemote (class: Proxy for: ve.ekabod.lib.LibroBeanRemote)
| +- local (class: Proxy for: ve.ekabod.lib.LibroBeanLocal)
| +- remote (class: Proxy for: ve.ekabod.lib.LibroBeanRemote)
| +- local-ve.ekabod.lib.LibroBeanLocal (class: Proxy for: ve.ekabod.lib.LibroBeanLocal)

+- HiLoKeyGeneratorFactory (class: org.jboss.ejb.plugins.keygenerator.hilo.HiLoKeyGeneratorFactory)
...

*********************************************************************************************************************************
Im just copyng the .jar containing the EJB into my JBOSSfolder/server/default/deploy

I have no problems with the EJB, in fact the table is being generated perfectly, and im able to access it with another EJBs my issue is the following:

When trying to find the EJB from the Servlet im getting this message error:

*****************************From the Jboss console*************************************************************************
14:48:26,145 ERROR [STDERR] javax.naming.CannotProceedException; remaining name 'LibroBean/local'
14:48:26,190 ERROR [STDERR] at javax.naming.spi.ContinuationContext.getTargetContext(ContinuationContext.java:43)
14:48:26,190 ERROR [STDERR] at javax.naming.spi.NamingManager.getContinuationContext(NamingManager.java:770)
14:48:26,190 ERROR [STDERR] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:832)
14:48:26,190 ERROR [STDERR] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:686)
14:48:26,191 ERROR [STDERR] at javax.naming.InitialContext.lookup(InitialContext.java:392)
14:48:26,191 ERROR [STDERR] at ve.ekabod.lib.web.MainServlet.doGet(MainServlet.java:43)
14:48:26,191 ERROR [STDERR] at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
14:48:26,191 ERROR [STDERR] at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
14:48:26,191 ERROR [STDERR] at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
14:48:26,191 ERROR [STDERR] at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
14:48:26,191 ERROR [STDERR] at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
14:48:26,191 ERROR [STDERR] at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
14:48:26,191 ERROR [STDERR] at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
14:48:26,191 ERROR [STDERR] at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
14:48:26,192 ERROR [STDERR] at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
14:48:26,192 ERROR [STDERR] at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
14:48:26,192 ERROR [STDERR] at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
14:48:26,192 ERROR [STDERR] at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
14:48:26,192 ERROR [STDERR] at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
14:48:26,192 ERROR [STDERR] at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
14:48:26,192 ERROR [STDERR] at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
14:48:26,192 ERROR [STDERR] at java.lang.Thread.run(Thread.java:619)
**********************************************************************************************************

The source code extract from the servlet that is crashing is this:


Im afraid that there's something wrong in my web.xml, or im not stating in the servlet some information about the jdni properties or linking the EJB, i've tried modifying several times the web.xml whith examples i've found via googleing with no luck.
My web.XML is as follows



and i havent found the correct way to link the EJB here.

Please, can someone help me with this? i've wasted 2 days trying to solve this problem... Thanks in advance
JP

Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6662
    
    5

You might have better luck in the EJB forums. Looks like a bean lookup is failing. How did you define the bean deployment JNDI name ? Where is it bound in the JNDI tree ?


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
Juan Malle
Greenhorn

Joined: Nov 11, 2009
Posts: 2
fixed it already, but forgot to update this post

I just changed the way i was looking up the EJB by this


In fact up in the bean i had the ejb's jndis names



How did you define the bean deployment JNDI name ? Where is it bound in the JNDI tree ?


your questions may solved the problem Deepak, you were right.. thanks
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6662
    
    5

Glad to hear your problem was solved. Thanks for sharing the answer
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: javax.naming.CannotProceedException; remaining name