File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem deploying service on Ubuntu Virtual Machine

 
Rafael Angarita
Ranch Hand
Posts: 67
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have a web service that works perfectly fine when I deploy it on localhost. Now I'm deploying it on a virtual machine with Ubuntu and I get this exception when I try to use it:



Test helper at line 21


TUSB_RegCivil at line 28


And hibernateUtil :



Any of you guys have any idea of what may be happening?

Im using JAX-WS with Glassfish.

Thank you very much guys.
 
Rafael Angarita
Ranch Hand
Posts: 67
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I also found this:



Also, I deployed it on another VM with Windows XP and it works fine too. I seem that it does not work only on my Ubuntu VM.

My host OS is Mac OS

Thank you
 
Ivan Krizsan
Ranch Hand
Posts: 2198
1
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
What JVM are you running in the Ubuntu VM?
Make sure that you are using a Sun VM, not the GNU dito that often is distributed with Linux etc.
In one case I had to completely delete the GNU VM to resolve the problems I had.
Best wishes!
 
Rafael Angarita
Ranch Hand
Posts: 67
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you Ivan. Your answers have been really helpful for me!

I'm also using your study notes to learn about securing web services.They are excellent.

I did what you said regarding this problem, but it could not solve it.

I also tried with a simple web service (with no hibernate nor connection to a db) and it worked fine.

It is only the web service with hibernate that doesn't work on my Ubuntu installation.

Any ideas of what I should do? or any advise of how I can troubleshoot this problem?

Thank you very much!
 
Ivan Krizsan
Ranch Hand
Posts: 2198
1
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
Regretfully, I have no idea where the problem may be but, if I were in your situation, I would try to run some other, non-web service, program that uses Hibernate in the same way as the web service in your Ubuntu VM. If possible, try make this test program a standalone program, that is, a program that does not need to run in a container.
Best wishes!
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic