This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes JBoss/WildFly and the fly likes 404 error for a deployed EAR. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "404 error for a deployed EAR." Watch "404 error for a deployed EAR." New topic
Author

404 error for a deployed EAR.

Winston Mandel
Greenhorn

Joined: Nov 17, 2009
Posts: 5
Hello Everyone,

I am deploying a large application with approx - 12 WARs and JARs bundled in an EAR file. However I am unable to reach the application page from browser.

A few things I have verified -
1. Server log, I don't see any exception. It's a clean deploy.
2. Server console shows that the application is deployed. All the app components are deployed correctly, all the descriptors are correct.
3. An earlier version of the app works fine when deployed from Eclipse as an exploded app i.e. not as an EAR. I am trying to get it working towards CI using ANT and Continuum.

JBoss version is 4.2.3, JRE is 1.6, the code is compiled using ANT for target version of 1.5.

I can post the logs too, but, before that wanted to check with the group if there are any other checks that I am missing. Any pointer or clues would be truly appreciated.

Thank you.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

Win Man, please read your private messages for an important administrative matter. Once that is taken care of, I can provide some suggestions for your problem.


JBoss In Action
Winston Mandel
Greenhorn

Joined: Nov 17, 2009
Posts: 5
Just did, thank you. Awaiting your response!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: 404 error for a deployed EAR.