Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

404 error for a deployed EAR.

 
Winston Mandel
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Everyone,

I am deploying a large application with approx - 12 WARs and JARs bundled in an EAR file. However I am unable to reach the application page from browser.

A few things I have verified -
1. Server log, I don't see any exception. It's a clean deploy.
2. Server console shows that the application is deployed. All the app components are deployed correctly, all the descriptors are correct.
3. An earlier version of the app works fine when deployed from Eclipse as an exploded app i.e. not as an EAR. I am trying to get it working towards CI using ANT and Continuum.

JBoss version is 4.2.3, JRE is 1.6, the code is compiled using ANT for target version of 1.5.

I can post the logs too, but, before that wanted to check with the group if there are any other checks that I am missing. Any pointer or clues would be truly appreciated.

Thank you.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Win Man, please read your private messages for an important administrative matter. Once that is taken care of, I can provide some suggestions for your problem.
 
Winston Mandel
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just did, thank you. Awaiting your response!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic