my dog learned polymorphism*
The moose likes IDEs, Version Control and other tools and the fly likes Problem Starting Jboss 5.1.0GA from eclipse 3.4.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Problem Starting Jboss 5.1.0GA from eclipse 3.4.1" Watch "Problem Starting Jboss 5.1.0GA from eclipse 3.4.1" New topic
Author

Problem Starting Jboss 5.1.0GA from eclipse 3.4.1

hem kumar
Ranch Hand

Joined: Sep 05, 2005
Posts: 97
Hi all, i want to add the jboss 5.1.0 GA server to eclipse 3.4.1 IDE, so that to be able to start and stop it from within the eclipse environment. But i'm not able to do that as i dont see any option to add it in add server option in eclipse. The most i see is upto jboss 5.0 support. And even if i try to add jboss 5.4.1 from jboss 5.0 option it always hangs up after some seconds. Is there any plugin available so that i can start it easily from within eclipse. And how to change the defult port option in jboss? thank you all.

.....For Every Problem There Is a Solution.....
Regards, Hem
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5811
    
    7

I'm trying to recall if I had this issue, but cannot. One of the problems in earlier releases of Eclipse is that they supported the earlier beta versions of Jboss AS 5, but somewhere in the late betas or candidate release, the "primary" JAR files move to other locations.

I can think of a few ways that you can attempt to fix this:

a) Move up to Eclipse 3.5 and use the "JBoss 5.0" entry
b) Install JBoss Tools and use the "Jboss AS 5.1" entry under "JBoss Community"
c) Edit the plugins/org.eclipse.jst.server.generic.jboss_1.6.1.v200904151730/servers/jboss5.serverdef to specify the correct locations of the "primary" JAR files. (Thise version number is from Eclipse 3.5, it might be different in 3.4)
d) Do "a)" and "b)" - move up to Eclipse 3.5 and install JBoss Tools. (My recommendation)


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem Starting Jboss 5.1.0GA from eclipse 3.4.1
 
Similar Threads
Producing a Build of an Application Developed Eclipse WTP
In MAC, Findbugs not appearing in Eclipse 3.4.1
Configuring WebSphere V6.0 with Eclipse 3.4.1
java.lang.ClassNotFoundException: oracle.jdbc.oracle.OracleDriver
Running First EJB-in Eclipse using JBoss!