aspose file tools*
The moose likes Struts and the fly likes Struts 2 problem in Tomcat Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts 2 problem in Tomcat" Watch "Struts 2 problem in Tomcat" New topic
Author

Struts 2 problem in Tomcat

Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9383
    
    2

Guys,

I have a Spring 2.x.x / Struts 2.0 application deployed to Tomcat 6.x. When I package my application and deploy it to tomcat, the app is noet getting started and I saw in the log files that there seems to be some problems with the filters that I use. Here is a snippet of my log file as printed in the Tomcat console.



I checked the exploded war in the tomcat webapps directory for this web application and the struts.xml files are in the proper location (under WEB-INF/classes), but do not understand why this problem persists? Any ideas?


SCJP 1.4, SCWCD 1.4 - Hints for you, Certified Scrum Master
Did a rm -R / to find out that I lost my entire Linux installation!
Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9383
    
    2

I realized that I missed the tiles plugin and added that as a dependency to my pom.xml. Though it looked better, the error still persists. Here is the log entry:

Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9383
    
    2

Checked the tomcat logs and found the stack trace as below,



I have specified in my struts.properties file to use spring as my ObjectFactory and does this imply that I have to include some additional dependencies for my app? Is there anything like the struts - spring plugin? Could it be because of that?
Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9383
    
    2

As I guessed it, I was missing this plugin. I added it to my pom and the error vanished. Hope this helps someone...
 
wood burning stoves
 
subject: Struts 2 problem in Tomcat