File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Services and the fly likes Wsdl2java Issues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Wsdl2java Issues" Watch "Wsdl2java Issues" New topic
Author

Wsdl2java Issues

H Bhoon
Greenhorn

Joined: May 18, 2009
Posts: 7
Hi all,
I use wsdl2java to generate the java objects from a WSDL. I have the following mapping in my NStoPkg.properties file:



When I run wsdl2java, i get the following messages logged out:



These messages (and the lack of java objects in my target directory) tells me that no objects in either the namespace "urn:mbtu/wsdl" or the namespace "urn:mbtu/types" was generated. Note that all objects in the namespace "common/types" (the third namespace I defined in my NStoPkg.properties file) does generate perfectly!

Why is this? The logged messages say that QName "mbtu/types" and "mbtu/wsdl" isn't included. Included in what? It is definitely defined in my NStoPkg.properties file. What config/step am I missing?

Kind regards and thanks in advance.

H Bhoon
Greenhorn

Joined: May 18, 2009
Posts: 7
Hi all,
Solved my own problem eventually! I'm posting this reply in case anybody else ever has this same problem and happens upon this post. I run wsdl2java from my Eclipse workspace using Maven. In my project's pom.xml I needed to include the following namespace includes list (thus my "excluding code generation for non-included QName" error):



Kind regards,
hb
 
 
subject: Wsdl2java Issues