wood burning stoves 2.0*
The moose likes Web Services Certification (SCDJWS/OCEJWSD) and the fly likes Getting error while testing Web Service. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Certification » Web Services Certification (SCDJWS/OCEJWSD)
Bookmark "Getting error while testing Web Service." Watch "Getting error while testing Web Service." New topic
Author

Getting error while testing Web Service.

Ankita Agarwal
Greenhorn

Joined: Nov 10, 2009
Posts: 7
Hi,

I am running examples from Ivan's guide : Calculator service and String Processor.
For both of the services i did testing by right clicking the WSDL file and selecting Web Services → Test with Web Services Explorer. I am getting the Web Service Explorer page but after giving inputs i m not getting any output. Instead i m getting this status:

"IWAB0135E An unexpected error has occurred.
404
Not Found"

I am unable to see any request or response message and output in console.
I am using Eclipse3.1 and Glassfishv3 prelude.
Please anyone explain me.

Thanks ,
Ankita
Ivan Krizsan
Ranch Hand

Joined: Oct 04, 2006
Posts: 2198
    
    1
Hi!
Are you able to access the WSDL of the web service from a browser?
If not, then the error is probably caused by the web service not having been deployed correctly.
Please try to redeploy and pay special attention to the server log when you are deploying.
Best wishes!
Ankita Agarwal
Greenhorn

Joined: Nov 10, 2009
Posts: 7
Hi Ivan,

Thanks for your reply.

Im able to access WSDL through browser.Also I have redeployed the application .Still it is not working.

It seems I have missed out something .
Sysout statements in my Calculator class are also not getting printed .
My Calculator class resides in the pkg: com.myws.Calculator(Does that mean that service is not getting invoked.)
Do I have to give this somewhere in the WSDL.

Thanks ,
Ankita.

Ivan Krizsan
Ranch Hand

Joined: Oct 04, 2006
Posts: 2198
    
    1
Hi!
Have you tried following the example in the document without changing anything?
If not, I advise you to do that and, once you have that working but not until then, start changing things.
Best wishes!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Getting error while testing Web Service.
 
Similar Threads
Web Service with Input as XML
IWAB0135E An unexpected error has occurred.
Web Services with Websphere
output in firefox
Eclipse web service client - remote server