This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Websphere and the fly likes WAS + HTTP configuration Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS + HTTP configuration" Watch "WAS + HTTP configuration" New topic
Author

WAS + HTTP configuration

dhanu manjula
Greenhorn

Joined: Aug 31, 2009
Posts: 19
Hi All,

This is my Server configurations



If I hit for snoop servlet from following URL (with http port & application server port) it is working!!

WAS : http://192.168.10.2:10207/snoop
HTTP: http://192.168.10.2:22207/snoop

I installed a simple servlet base application on WAS. From application server end, It can access through the following URL

http://192.168.10.2:10207/PolcSearch1/index.jsp

Then it redirect to this
http://192.168.10.2:22207/PolcSearch1/PolicySearchServlet
and show me the result. Everything ok!!

But problem is, if I call that application from http server end:
http://192.168.10.2:22207/PolcSearch1/index.jsp

It shows redirect to the URL :
http://192.168.10.2:22207/PolcSearch1/PolicySearchServlet

But no any result!! And say


Any tips to help me along would be much appreciated.

dhanuxp
Anant Rao
Ranch Hand

Joined: Nov 12, 2004
Posts: 126
After you deployed the servlet app, did you regenerate the plugin and transferred to IHS ?

Anant
dhanu manjula
Greenhorn

Joined: Aug 31, 2009
Posts: 19
Anant Rao wrote:After you deployed the servlet app, did you regenerate the plugin and transferred to IHS ?

Anant



Hello Anant Rao,

Me, again, i'm still having some trouble with a HTTP+WAS configuration, i'm not sure what is wrong, it should be working, Please help me….
It occurred following error now,


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.



what I did here, Correct me if I'm wrong

Connected to WAS administrative console > Server > WebServer > Click HIS_MYSERVER > click Generate Plug-in button

Then restarted the Webserver

Then type following URL http://192.168.10.2:22207/PolcSearch1/index.jsp & ends up with above error.

IBM HTTP & WAS 6.0 is running on same machine & my OS version is V5R4
Any idea please...

Thanks
Dhanuxp
dhanu manjula
Greenhorn

Joined: Aug 31, 2009
Posts: 19
dhanu manjula wrote:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.




anyone else seen this before ???


Thanks
dhanuxp
Deepak Pant
Ranch Hand

Joined: Feb 13, 2004
Posts: 443
I would suggest you to check following two things:

1. Check if you have proper webcontext (or request context) defined in the descriptors.

2. Open the plug-in config file (in IHS machine) and check if your web context is defined there.
dhanu manjula
Greenhorn

Joined: Aug 31, 2009
Posts: 19
Deepak Pant wrote:I would suggest you to check following two things:

1. Check if you have proper webcontext (or request context) defined in the descriptors.

2. Open the plug-in config file (in IHS machine) and check if your web context is defined there.


Hello Deepak,
many Thanks, my DD looks like this



What did i miss??

Thanks again
dhanu
Deepak Pant
Ranch Hand

Joined: Feb 13, 2004
Posts: 443
I think you pasted the contents of web.xml file. The web context root is either defined in "application.xml" as follows:

OR
You could define it in "ibm-web-ext.xml" file


Either case what I wanted you to check if web context root of your web app is present in your IHS Plug-in file.

The other thing you should do is check if WebSphere ISC (Integrated Services Console) shows the IHS as Web Server.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: WAS + HTTP configuration
 
Similar Threads
404 accessing Enterprise application under SSO
Locating a file from servlet using a relative path
How to Configuring SSL in was4.03 AE
Eclipse WTP Tutorial Error
Limit on Data/Key-Value Pairs in Form Submission