wood burning stoves
The moose likes JDBC and Relational Databases and the fly likes reading BLOB type Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "reading BLOB type" Watch "reading BLOB type" New topic

reading BLOB type

nikil shar
Ranch Hand

Joined: May 25, 2008
Posts: 116
hi all,
am trying to read a BLOB from an oracle db using java1.5 (ojdbc5.jar) and both getBinaryStream() and getBytes() returns null. Have inserted a BLOB in that row which i am fetching so i dont know why i am getting null ??

any suggestions on what could be wrong ??


Scott Selikoff
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3749

Have you tried getBlob()?

[OCA 8 Book] [Blog]
nikil shar
Ranch Hand

Joined: May 25, 2008
Posts: 116
yes have tried getBlob() but it still returns null. Have found that the BLOB in the db is actually null even though when i insert BLOB there are no errors thrown and it looks like the insert worked !!

ran this sql to find out the length of BLOB and they are all null :

heres how i insert the BLOB :

Please point out if you see anything wrong with the insert BLOB code.

I agree. Here's the link: http://aspose.com/file-tools
subject: reading BLOB type
It's not a secret anymore!