Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Nested table output is coming as "???" in Java

 
nedumangad chandra
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am having a procedure which outputs one nested table having some varchar data.I can access that "String" values from java using the code (this is not full code..only part of it)

This code works perfectly in "Oracle Database 10g Enterprise Edition Release 10.1.0.4.0 - Prod"
But when I connected to a different database(database objects are same),but version is different.i.e,
"Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Prod"...I am getting "???" as string values.
Why these question marks are coming instead of proper string values.Please help...
 
Tim McGuire
Ranch Hand
Posts: 820
IntelliJ IDE Tomcat Server VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you post more of your code?
 
nedumangad chandra
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tim McGuire wrote:Can you post more of your code?

I am getting connection using the code below

the database credentials are set in the server.xml in my tomcat server.I have installed the client oracle version in my system.But what is the significance of that info ? I can get string values in proper format in my Toad .
I am taking the nested table values using java.sql.SQLData.Please see the code below.

argZero.readString() is giving "???".Please reply.
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is the charset that the DB uses ?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic