This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Web Services and the fly likes Problem while calling external web-service in WAS 6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Problem while calling external web-service in WAS 6.1" Watch "Problem while calling external web-service in WAS 6.1" New topic
Author

Problem while calling external web-service in WAS 6.1

Abhay Narkhede
Greenhorn

Joined: Dec 15, 2009
Posts: 3
I am facing one problem while calling external system's web-service in WAS 6.1 which works fine in WAS 6.0

I have used SOAPConnection class to call external webservice.
In WAS 6.0, if no data is returned from the webservice, the response object is returned with the fault code.This response is handled at client side to show proper error message(No Data Found) to the user.

But in WAS 6.1, if no data is returned from the webservice, exception is thrown instead of response. Hence, the error message (No Data Found) is not displayed to the user.

I think, SOAPConnection class is interpreting the response from the webservice differently in WAS 6.0 and WAS 6.1.

Is there any way to resolve this issue by re-writing the connection call ?
Is there any feature of SOAPConnection available in WAS 6.1 (jax-ws) to resolve this issue ?

 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Problem while calling external web-service in WAS 6.1
 
Similar Threads
Connection pooling of SOAPConnection objects
Control character when retrieving a field from an Oracle Array
Webservice Exception in RAD7
Invoking HTTPS webservice
stop synchronous web service call