aspose file tools*
The moose likes BEA/Weblogic and the fly likes jaxb-rt-1.0-ea.jar error during WEBLOGIC10.3 migration Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "jaxb-rt-1.0-ea.jar error during WEBLOGIC10.3 migration" Watch "jaxb-rt-1.0-ea.jar error during WEBLOGIC10.3 migration" New topic
Author

jaxb-rt-1.0-ea.jar error during WEBLOGIC10.3 migration

srinivas sar
Greenhorn

Joined: Dec 02, 2009
Posts: 5
Hi,

We are getting below error when migrate our JAXB from weblogic 9.2 to 10.3.

java.lang.NoSuchFieldError: INITIAL_COLOR
at javax.xml.bind.ValidatableObject.<init>(ValidatableObject.java:32)
at javax.xml.bind.MarshallableObject.<init>(MarshallableObject.java:54)
at javax.xml.bind.MarshallableRootElement.<init>(MarshallableRootElement.java:97)

please help.

-Srini
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6662
    
    5

Did you recompile the newly generated java files ?


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
Steve Singer
Greenhorn

Joined: Feb 23, 2010
Posts: 3
Your problem is likely not Weblogic, but a new version of Java. Java 1.6 includes many of the JAXB classes in there with exactly the same names as the 1.0 version but different implementation, so it will break. Try running under Java 1.5.
Mohammad Husain
Greenhorn

Joined: Jun 17, 2011
Posts: 1
Steve Singer wrote:Your problem is likely not Weblogic, but a new version of Java. Java 1.6 includes many of the JAXB classes in there with exactly the same names as the 1.0 version but different implementation, so it will break. Try running under Java 1.5.


Thanks. I was facing the same error, not with Weblogic though. Using Java 1.5 instead of 1.6 solved the problem.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: jaxb-rt-1.0-ea.jar error during WEBLOGIC10.3 migration