aspose file tools*
The moose likes Linux / UNIX and the fly likes Coonection to the remote host failed in ubuntu 9.10 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Coonection to the remote host failed in ubuntu 9.10" Watch "Coonection to the remote host failed in ubuntu 9.10" New topic
Author

Coonection to the remote host failed in ubuntu 9.10

sunil amperayani
Greenhorn

Joined: Dec 20, 2009
Posts: 7

I am using ubuntu 9.10 . I am able to ssh to other machines where as others cannot ssh to me . It displays as connection to the remote host failed.

1. I have disabled the firewall using ufw disable

2. there are no entries in /etc/hosts.allow and hosts.deny

3. I even checked in /var/log/messages which displays as connection refused

Guide me properly to disable the firewall
Marco Ehrentreich
best scout
Bartender

Joined: Mar 07, 2007
Posts: 1282

Hi Sunil,

I must admit that I usually use Gentoo, so I can't guarantee that my advices work exactly the same way for Ubuntu...
2. there are no entries in /etc/hosts.allow and hosts.deny

You can usually ignore these anyway because most modern network services offer more secure access controls.
3. I even checked in /var/log/messages which displays as connection refused

Are you sure there's no other hint which contains useful information?
Guide me properly to disable the firewall

I don't know what kind of firewall Ubuntu uses by default, but I'm pretty sure it's based on Netfilter/iptables. To disable it simply type in the console

This sets the default policy of the INPUT chain to "ACCEPT" which allows all inbound connections and it flushes all rules to delete rules which could explicitly block inbound conntections. WARNING!!! This is only meant for testing purposes! It doesn't only allow SSH traffic but instead it allows access from all sources with all protocols to your host! It's just the easiest way to find out if the problem is really the firefall!

That said, a typical firefall configuration usually doesn't lead to this error message! Instead the terminal would probably "hang" because packets are silently dropped. A "connection refused" error is more likely to indicate that the SSH server isn't even running. Could you check this?

Marco
Kedar Bhise
Greenhorn

Joined: Dec 29, 2009
Posts: 4
I would tend to agree with Marco on the SSH server running issue.

By default, Ubuntu does not have the sshd installed. Only the ssh client is installed.

Could you please verify that the sshd is installed and running?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Coonection to the remote host failed in ubuntu 9.10